parent
52e6fda4a6
commit
c35b409c01
@ -0,0 +1 @@
|
||||
/lazycell-0.5.1.crate
|
@ -0,0 +1,13 @@
|
||||
--- lazycell-0.5.1/Cargo.toml 2017-03-24T04:11:12+01:00
|
||||
+++ lazycell-0.5.1/Cargo.toml 2017-06-16T07:42:02.289128+02:00
|
||||
@@ -17,10 +17,3 @@
|
||||
"README.md",
|
||||
"src/**/*.rs",
|
||||
]
|
||||
-
|
||||
-[dependencies]
|
||||
-clippy = { version = "0.0", optional = true }
|
||||
-
|
||||
-[features]
|
||||
-nightly = []
|
||||
-nightly-testing = ["clippy", "nightly"]
|
@ -0,0 +1,58 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate lazycell
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Library providing a lazily filled Cell struct
|
||||
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/lazycell
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * clippy is nightly
|
||||
Patch0: lazycell-0.5.1-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
A library providing a lazily filled Cell struct.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Fri Jun 16 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
|
||||
- Initial package
|
Loading…
Reference in new issue