Update to 1.3.0

epel9
Josh Stone 6 years ago
parent 17a4355cb3
commit d5e9788a64

1
.gitignore vendored

@ -6,3 +6,4 @@
/lazy_static-1.0.2.crate /lazy_static-1.0.2.crate
/lazy_static-1.1.0.crate /lazy_static-1.1.0.crate
/lazy_static-1.2.0.crate /lazy_static-1.2.0.crate
/lazy_static-1.3.0.crate

@ -1,17 +1,14 @@
--- lazy_static-1.2.0/Cargo.toml 1969-12-31T16:00:00-08:00 --- lazy_static-1.3.0/Cargo.toml 1969-12-31T16:00:00-08:00
+++ lazy_static-1.2.0/Cargo.toml 2018-11-09T18:00:25.146845-08:00 +++ lazy_static-1.3.0/Cargo.toml 2019-02-28T09:25:59.738921-08:00
@@ -22,15 +22,9 @@ @@ -22,12 +22,7 @@
categories = ["no-std", "rust-patterns", "memory-management"] categories = ["no-std", "rust-patterns", "memory-management"]
license = "MIT/Apache-2.0" license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang-nursery/lazy-static.rs" repository = "https://github.com/rust-lang-nursery/lazy-static.rs"
-[dependencies.spin] -[dependencies.spin]
-version = "0.4.10" -version = "0.5.0"
-features = ["once"]
-optional = true -optional = true
-default-features = false
[features] -[features]
nightly = []
-spin_no_std = ["spin"] -spin_no_std = ["spin"]
[badges.appveyor] [badges.appveyor]
repository = "rust-lang-nursery/lazy-static.rs" repository = "rust-lang-nursery/lazy-static.rs"

@ -6,17 +6,16 @@
%global crate lazy_static %global crate lazy_static
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.2.0 Version: 1.3.0
Release: 2%{?dist} Release: 1%{?dist}
Summary: Macro for declaring lazily evaluated statics in Rust Summary: Macro for declaring lazily evaluated statics in Rust
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/lazy_static URL: https://crates.io/crates/lazy_static
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * Exclude CI files, https://github.com/rust-lang-nursery/lazy-static.rs/pull/127 # * Remove spin, it is not usable on stable (FIXME: still true?)
# * Remove spin, it is not usable on stable
Patch0: lazy_static-fix-metadata.diff Patch0: lazy_static-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -55,7 +54,7 @@ which use "default" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%build %build
@ -70,6 +69,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Thu Feb 28 2019 Josh Stone <jistone@redhat.com> - 1.3.0-1
- Update to 1.3.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (lazy_static-1.2.0.crate) = 0d80334da99292d68fb2ea9879540676fd45788547b7170b6df1b0a606c1645a07188837f9414196eb44ac63010a3c84fe5c4319478f6fc2cef837295a255edc SHA512 (lazy_static-1.3.0.crate) = 08288790139876765b6d4a5988f47fd2a4bfc77c2f2406ad44e64920a471b5655c7f54cb197e5a40c29ee8b42aecbbefaac2b6f4a7dd2b5e24dd92c46cb9b822

Loading…
Cancel
Save