remove spin

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent cf49f43965
commit abdefd9d97
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,10 +1,19 @@
--- lazy_static-1.1.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ lazy_static-1.1.0/Cargo.toml 2018-10-27T15:12:06.309029+02:00
@@ -22,6 +22,7 @@
+++ lazy_static-1.1.0/Cargo.toml 2018-10-27T22:39:22.137545+02:00
@@ -22,15 +22,12 @@
categories = ["no-std", "rust-patterns", "memory-management"]
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang-nursery/lazy-static.rs"
-[dependencies.spin]
-version = "0.4.6"
-optional = true
+exclude = ["/.travis.yml", "/appveyor.yml"]
[dependencies.spin]
version = "0.4.6"
optional = true
[build-dependencies.version_check]
version = "0.1.4"
[features]
nightly = []
-spin_no_std = ["nightly", "spin"]
[badges.appveyor]
repository = "rust-lang-nursery/lazy-static.rs"

@ -16,12 +16,12 @@ URL: https://crates.io/crates/lazy_static
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Exclude CI files, https://github.com/rust-lang-nursery/lazy-static.rs/pull/127
# * Remove spin, it is not usable on stable
Patch0: lazy_static-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(spin/default) >= 0.4.6 with crate(spin/default) < 0.5.0)
BuildRequires: (crate(version_check/default) >= 0.1.4 with crate(version_check/default) < 0.2.0)
%global _description \
@ -55,18 +55,6 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+spin-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+spin-devel %{_description}
This package contains library source intended for building other packages
which use "spin" feature of "%{crate}" crate.
%files -n %{name}+spin-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

Loading…
Cancel
Save