Update to 1.2.0

epel9
Josh Stone 6 years ago
parent abdefd9d97
commit 7a328c3bac

1
.gitignore vendored

@ -5,3 +5,4 @@
/lazy_static-1.0.1.crate
/lazy_static-1.0.2.crate
/lazy_static-1.1.0.crate
/lazy_static-1.2.0.crate

@ -1,19 +1,18 @@
--- lazy_static-1.1.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ lazy_static-1.1.0/Cargo.toml 2018-10-27T22:39:22.137545+02:00
@@ -22,15 +22,12 @@
--- lazy_static-1.2.0/Cargo.toml 1969-12-31T16:00:00-08:00
+++ lazy_static-1.2.0/Cargo.toml 2018-11-09T18:00:25.146845-08:00
@@ -22,15 +22,9 @@
categories = ["no-std", "rust-patterns", "memory-management"]
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang-nursery/lazy-static.rs"
-[dependencies.spin]
-version = "0.4.6"
-version = "0.4.10"
-features = ["once"]
-optional = true
+exclude = ["/.travis.yml", "/appveyor.yml"]
[build-dependencies.version_check]
version = "0.1.4"
-default-features = false
[features]
nightly = []
-spin_no_std = ["nightly", "spin"]
-spin_no_std = ["spin"]
[badges.appveyor]
repository = "rust-lang-nursery/lazy-static.rs"

@ -6,8 +6,8 @@
%global crate lazy_static
Name: rust-%{crate}
Version: 1.1.0
Release: 3%{?dist}
Version: 1.2.0
Release: 1%{?dist}
Summary: Macro for declaring lazily evaluated statics in Rust
# Upstream license specification: MIT/Apache-2.0
@ -22,7 +22,6 @@ Patch0: lazy_static-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(version_check/default) >= 0.1.4 with crate(version_check/default) < 0.2.0)
%global _description \
A macro for declaring lazily evaluated statics in Rust.
@ -71,6 +70,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Sat Nov 10 2018 Josh Stone <jistone@redhat.com> - 1.2.0-1
- Update to 1.2.0
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.1.0-3
- Adapt to new packaging

@ -1 +1 @@
SHA512 (lazy_static-1.1.0.crate) = 82df91ddf79e2c6e46cda92d6dc8afe20d428f40940a16a352db3c3482ec21ec4b5147bf723dd0b16320ebe0fea489d715671c7fecaf8d0d7982edad3b6919c5
SHA512 (lazy_static-1.2.0.crate) = 0d80334da99292d68fb2ea9879540676fd45788547b7170b6df1b0a606c1645a07188837f9414196eb44ac63010a3c84fe5c4319478f6fc2cef837295a255edc

Loading…
Cancel
Save