bump tokio-process to 0.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent f0ec7ce386
commit ed87102588
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,34 @@
From 949a7778db0d181dbae3cc9e9074f1bb284b7c43 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Thu, 14 Jun 2018 11:51:07 +0200
Subject: [PATCH] bump tokio-process to 0.2
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
tests/client.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/tests/client.rs b/tests/client.rs
index 4147191..69b88ea 100644
--- a/tests/client.rs
+++ b/tests/client.rs
@@ -115,7 +115,6 @@ fn main() {
let filter = env::args().skip(1).next();
let mut core = t!(Core::new());
- let ref handle = core.handle();
let futures = TESTS.iter().filter(|test| {
match filter {
@@ -136,7 +135,7 @@ all:
cmd.args(test.make_args);
cmd.current_dir(td.path());
future::lazy(move || {
- cmd.output_async(&handle).map(move |e| {
+ cmd.output_async().map(move |e| {
drop(td);
(test, e)
})
--
2.18.0.rc1

@ -1,8 +0,0 @@
--- jobserver-0.1.10/Cargo.toml 1969-12-31T16:00:00-08:00
+++ jobserver-0.1.10/Cargo.toml 2018-03-12T17:19:05.892868-07:00
@@ -60,5 +60,3 @@
version = "0.1"
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.rand]
-version = "0.4"

@ -0,0 +1,12 @@
--- jobserver-0.1.11/Cargo.toml 1970-01-01T01:00:00+01:00
+++ jobserver-0.1.11/Cargo.toml 2018-06-14T11:54:13.368046+02:00
@@ -57,8 +57,6 @@
version = "0.1"
[dev-dependencies.tokio-process]
-version = "0.1"
+version = "0.2"
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.rand]
-version = "0.4"

@ -6,7 +6,7 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.11 Version: 0.1.11
Release: 1%{?dist} Release: 2%{?dist}
Summary: Implementation of the GNU make jobserver for Rust Summary: Implementation of the GNU make jobserver for Rust
License: MIT or ASL 2.0 License: MIT or ASL 2.0
@ -14,7 +14,10 @@ URL: https://crates.io/crates/jobserver
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * No windows # * No windows
Patch0: jobserver-0.1.10-fix-metadata.diff # * Bump tokio-process to 0.2, https://github.com/alexcrichton/jobserver-rs/pull/8
Patch0: jobserver-0.1.11-fix-metadata.diff
# Make it work with new tokio-process
Patch1: 0001-bump-tokio-process-to-0.2.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -28,7 +31,7 @@ BuildRequires: (crate(futures) >= 0.1.0 with crate(futures) < 0.2.0)
BuildRequires: (crate(num_cpus) >= 1.0.0 with crate(num_cpus) < 2.0.0) BuildRequires: (crate(num_cpus) >= 1.0.0 with crate(num_cpus) < 2.0.0)
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0) BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
BuildRequires: (crate(tokio-core) >= 0.1.0 with crate(tokio-core) < 0.2.0) BuildRequires: (crate(tokio-core) >= 0.1.0 with crate(tokio-core) < 0.2.0)
BuildRequires: (crate(tokio-process) >= 0.1.0 with crate(tokio-process) < 0.2.0) BuildRequires: (crate(tokio-process) >= 0.2.0 with crate(tokio-process) < 0.3.0)
%endif %endif
%description %description
@ -65,6 +68,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version}/
%changelog %changelog
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.11-2
- Bump tokio-process to 0.2
* Wed Mar 14 2018 Josh Stone <jistone@redhat.com> - 0.1.11-1 * Wed Mar 14 2018 Josh Stone <jistone@redhat.com> - 0.1.11-1
- Update to 0.1.11 - Update to 0.1.11

Loading…
Cancel
Save