Update to 0.1.12

epel9
Josh Stone 6 years ago
parent 0a7bdcb3d8
commit 8bc9f2c635

1
.gitignore vendored

@ -1,3 +1,4 @@
/jobserver-0.1.9.crate
/jobserver-0.1.10.crate
/jobserver-0.1.11.crate
/jobserver-0.1.12.crate

@ -1,34 +0,0 @@
From 949a7778db0d181dbae3cc9e9074f1bb284b7c43 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Thu, 14 Jun 2018 11:51:07 +0200
Subject: [PATCH] bump tokio-process to 0.2
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
tests/client.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/tests/client.rs b/tests/client.rs
index 4147191..69b88ea 100644
--- a/tests/client.rs
+++ b/tests/client.rs
@@ -115,7 +115,6 @@ fn main() {
let filter = env::args().skip(1).next();
let mut core = t!(Core::new());
- let ref handle = core.handle();
let futures = TESTS.iter().filter(|test| {
match filter {
@@ -136,7 +135,7 @@ all:
cmd.args(test.make_args);
cmd.current_dir(td.path());
future::lazy(move || {
- cmd.output_async(&handle).map(move |e| {
+ cmd.output_async().map(move |e| {
drop(td);
(test, e)
})
--
2.18.0.rc1

@ -1,12 +0,0 @@
--- jobserver-0.1.11/Cargo.toml 1970-01-01T01:00:00+01:00
+++ jobserver-0.1.11/Cargo.toml 2018-06-14T11:54:13.368046+02:00
@@ -57,8 +57,6 @@
version = "0.1"
[dev-dependencies.tokio-process]
-version = "0.1"
+version = "0.2"
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.rand]
-version = "0.4"

@ -0,0 +1,8 @@
--- jobserver-0.1.12/Cargo.toml 1969-12-31T16:00:00-08:00
+++ jobserver-0.1.12/Cargo.toml 2018-12-03T11:25:15.859774-08:00
@@ -60,5 +60,3 @@
version = "0.2"
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.rand]
-version = "0.6"

@ -6,8 +6,8 @@
%global crate jobserver
Name: rust-%{crate}
Version: 0.1.11
Release: 6%{?dist}
Version: 0.1.12
Release: 1%{?dist}
Summary: Implementation of the GNU make jobserver for Rust
# Upstream license specification: MIT/Apache-2.0
@ -16,10 +16,7 @@ URL: https://crates.io/crates/jobserver
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows
# * Bump tokio-process to 0.2, https://github.com/alexcrichton/jobserver-rs/pull/8
Patch0: jobserver-0.1.11-fix-metadata.diff
# Make it work with new tokio-process
Patch1: 0001-bump-tokio-process-to-0.2.patch
Patch0: jobserver-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -81,6 +78,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Mon Dec 03 2018 Josh Stone <jistone@redhat.com> - 0.1.12-1
- Update to 0.1.12
* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 0.1.11-6
- Adapt to new packaging

@ -1 +1 @@
SHA512 (jobserver-0.1.11.crate) = daf8e7e994fcbf7df5265e78d3d95f2e1d3e26d2deaa43213d75e33d5a2bc1c7c7bf66aae42a0ecde7aa59514cf70d16bcdc6198fd84f244d197bb1d09f15fd3
SHA512 (jobserver-0.1.12.crate) = 228af0a4174698b33be5ca5d1e87aac917e8d222f06594c7c69fcc541d0aba773012b791729c3e0669335147b62ce72259baf3ac0c9ededa3ef7c76752fbebe1

Loading…
Cancel
Save