import rust-jiff-0.1.18-1.el10

i10ce changed/i10ce/rust-jiff-0.1.18-1.el10
MSVSphere Packaging Team 1 month ago
parent 925aade987
commit ea1f1c3d05
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -1 +1 @@
SOURCES/jiff-0.1.16.crate
SOURCES/jiff-0.1.18.crate

@ -1 +1 @@
218aa3d7610d0dfdc35628bf1d39b78bad361a48 SOURCES/jiff-0.1.16.crate
49cd2d86f78db93e3b01d4943d059e41464ac4a1 SOURCES/jiff-0.1.18.crate

@ -1,4 +1,4 @@
From 684ec78f8f001e65d3778b5e8f0661d41d3c4a8a Mon Sep 17 00:00:00 2001
From cc1d9dff0b581f8a33268b3d2495b60d2b770d4c Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Thu, 26 Dec 2024 18:51:44 -0500
Subject: [PATCH] Downstream-only: omit tests that require serde_yml
@ -14,7 +14,7 @@ Subject: [PATCH] Downstream-only: omit tests that require serde_yml
7 files changed, 14 insertions(+)
diff --git a/src/civil/date.rs b/src/civil/date.rs
index 1b413fe..039bc97 100644
index 214c988..9a35c0b 100644
--- a/src/civil/date.rs
+++ b/src/civil/date.rs
@@ -4009,6 +4009,8 @@ mod tests {
@ -66,7 +66,7 @@ index f002d7c..8e8a42b 100644
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/span.rs b/src/span.rs
index ebe96e5..93f8f0d 100644
index 9a00d04..ffad9d2 100644
--- a/src/span.rs
+++ b/src/span.rs
@@ -6464,6 +6464,8 @@ mod tests {
@ -79,29 +79,29 @@ index ebe96e5..93f8f0d 100644
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/timestamp.rs b/src/timestamp.rs
index 79230b4..83c366c 100644
index 88ae03b..5cdd65b 100644
--- a/src/timestamp.rs
+++ b/src/timestamp.rs
@@ -3701,6 +3701,8 @@ mod tests {
@@ -3700,6 +3700,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
/// A `serde` deserializer compatibility test.
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/zoned.rs b/src/zoned.rs
index 1627167..5bea022 100644
index 70e88e7..80e9b26 100644
--- a/src/zoned.rs
+++ b/src/zoned.rs
@@ -5251,6 +5251,8 @@ mod tests {
@@ -5264,6 +5264,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
/// A `serde` deserializer compatibility test.
///
/// Serde YAML used to be unable to deserialize `jiff` types,
--

@ -1,22 +0,0 @@
From 692c9f7ebe20450269666cddeca75023c8a34a79 Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Thu, 26 Dec 2024 16:04:32 -0500
Subject: [PATCH] Fix a small typo in CHANGELOG.md
---
CHANGELOG.md | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 6281f33..e0f1c5a 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -72,7 +72,7 @@ adding duration to now: 2026-02-26T19:00:57-05:00[America/New_York]
With Jiff, you should no longer need to pull in crates like
[`humantime`](https://docs.rs/humantime) and
[`humantime-serde`](https://docs.rs/humantime-serde)
-to accomplished a similar task.
+to accomplish a similar task.
While this new format doesn't support any kind of internationalization, the
prevalence of the `humantime` crate suggests there's a desire for something

@ -1,6 +1,14 @@
--- jiff-0.1.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.16/Cargo.toml 2024-12-27T00:19:01.399220+00:00
@@ -142,8 +142,6 @@
--- jiff-0.1.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.18/Cargo.toml 2025-01-01T14:01:32.621821+00:00
@@ -137,7 +137,6 @@
[features]
alloc = [
"serde?/alloc",
- "portable-atomic-util/alloc",
]
default = [
"std",
@@ -146,8 +145,6 @@
"tzdb-zoneinfo",
]
js = [
@ -9,7 +17,7 @@
]
logging = ["dep:log"]
serde = ["dep:serde"]
@@ -153,38 +151,16 @@
@@ -158,46 +155,16 @@
]
tz-system = [
"std",
@ -40,6 +48,14 @@
[target.'cfg(not(target_family = "wasm"))'.dev-dependencies.hifitime]
version = "3.9.0"
-[target.'cfg(not(target_has_atomic = "ptr"))'.dependencies.portable-atomic]
-version = "1.10.0"
-default-features = false
-
-[target.'cfg(not(target_has_atomic = "ptr"))'.dependencies.portable-atomic-util]
-version = "0.2.4"
-default-features = false
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = ">=0.52.0, <=0.59.*"
-features = [

@ -1,6 +1,6 @@
--- jiff-0.1.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.16/Cargo.toml 2024-12-27T00:19:01.401220+00:00
@@ -113,9 +113,6 @@
--- jiff-0.1.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.18/Cargo.toml 2025-01-01T14:01:32.622821+00:00
@@ -114,9 +114,6 @@
[dev-dependencies.serde_json]
version = "1.0.117"
@ -10,7 +10,7 @@
[dev-dependencies.tabwriter]
version = "1.4.0"
@@ -161,6 +158,3 @@
@@ -165,6 +162,3 @@
]
tzdb-zoneinfo = ["std"]

@ -53,13 +53,6 @@ comments = [
""",
]
[[package.extra-patches]]
number = 13
file = "https://github.com/BurntSushi/jiff/pull/173.patch"
comments = [
"Fix a small typo in CHANGELOG.md",
]
[[package.extra-patches]]
number = 1009
file = "0001-EPEL9-Ignore-doctests-that-require-very-recent-Rust-.patch"

@ -15,7 +15,7 @@
%global crate jiff
Name: rust-jiff
Version: 0.1.16
Version: 0.1.18
Release: %autorelease
Summary: Date-time library that encourages you to jump into the pit of success
@ -36,8 +36,6 @@ Patch10: 0001-Downstream-only-Omit-doctests-that-require-hifitime.patch
Patch11: 0001-Downstream-only-Omit-doctests-that-require-icu.patch
# * Downstream-only: Omit tests that require serde_yml.
Patch12: 0001-Downstream-only-omit-tests-that-require-serde_yml.patch
# * Fix a small typo in CHANGELOG.md
Patch13: https://github.com/BurntSushi/jiff/pull/173.patch
# * EPEL9: Ignore doctests that require very recent Rust compilers
# * In this crate, doctests and examples (but not the lib and integration tests)
# are allowed to use Rust features from versions newer than the MSRV. Its
@ -202,6 +200,12 @@ tomcli set Cargo.toml append package.exclude test test-wasm 'scripts/*'
%changelog
## START: Generated by rpmautospec
* Wed Jan 01 2025 Benjamin A. Beasley <code@musicinmybrain.net> - 0.1.18-1
- Update to 0.1.18 (close RHBZ#2335119)
* Tue Dec 31 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.1.17-1
- Update to 0.1.17 (close RHBZ#2335070)
* Fri Dec 27 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.1.16-1
- Update to 0.1.16 (close RHBZ#2334259)

Loading…
Cancel
Save