Update to 0.1.16 (close RHBZ#2334259)

epel10 imports/epel10/rust-jiff-0.1.16-1.el10
Benjamin A. Beasley 1 month ago
parent 3ed04cf1e5
commit bd7ebcb666

1
.gitignore vendored

@ -4,3 +4,4 @@
/jiff-0.1.13.crate /jiff-0.1.13.crate
/jiff-0.1.14.crate /jiff-0.1.14.crate
/jiff-0.1.15.crate /jiff-0.1.15.crate
/jiff-0.1.16.crate

@ -0,0 +1,109 @@
From 684ec78f8f001e65d3778b5e8f0661d41d3c4a8a Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Thu, 26 Dec 2024 18:51:44 -0500
Subject: [PATCH] Downstream-only: omit tests that require serde_yml
---
src/civil/date.rs | 2 ++
src/civil/datetime.rs | 2 ++
src/civil/time.rs | 2 ++
src/signed_duration.rs | 2 ++
src/span.rs | 2 ++
src/timestamp.rs | 2 ++
src/zoned.rs | 2 ++
7 files changed, 14 insertions(+)
diff --git a/src/civil/date.rs b/src/civil/date.rs
index 1b413fe..039bc97 100644
--- a/src/civil/date.rs
+++ b/src/civil/date.rs
@@ -4009,6 +4009,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/civil/datetime.rs b/src/civil/datetime.rs
index e1249b3..ea14006 100644
--- a/src/civil/datetime.rs
+++ b/src/civil/datetime.rs
@@ -4280,6 +4280,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/civil/time.rs b/src/civil/time.rs
index c7d252b..dc8ca9f 100644
--- a/src/civil/time.rs
+++ b/src/civil/time.rs
@@ -3363,6 +3363,8 @@ mod tests {
assert_eq!(got, expected);
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/signed_duration.rs b/src/signed_duration.rs
index f002d7c..8e8a42b 100644
--- a/src/signed_duration.rs
+++ b/src/signed_duration.rs
@@ -2255,6 +2255,8 @@ mod tests {
assert_eq!(None, add((i64::MIN, -1), (0, -999_999_999)));
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/span.rs b/src/span.rs
index ebe96e5..93f8f0d 100644
--- a/src/span.rs
+++ b/src/span.rs
@@ -6464,6 +6464,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/timestamp.rs b/src/timestamp.rs
index 79230b4..83c366c 100644
--- a/src/timestamp.rs
+++ b/src/timestamp.rs
@@ -3701,6 +3701,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/zoned.rs b/src/zoned.rs
index 1627167..5bea022 100644
--- a/src/zoned.rs
+++ b/src/zoned.rs
@@ -5251,6 +5251,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
--
2.47.1

@ -0,0 +1,22 @@
From 692c9f7ebe20450269666cddeca75023c8a34a79 Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Thu, 26 Dec 2024 16:04:32 -0500
Subject: [PATCH] Fix a small typo in CHANGELOG.md
---
CHANGELOG.md | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 6281f33..e0f1c5a 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -72,7 +72,7 @@ adding duration to now: 2026-02-26T19:00:57-05:00[America/New_York]
With Jiff, you should no longer need to pull in crates like
[`humantime`](https://docs.rs/humantime) and
[`humantime-serde`](https://docs.rs/humantime-serde)
-to accomplished a similar task.
+to accomplish a similar task.
While this new format doesn't support any kind of internationalization, the
prevalence of the `humantime` crate suggests there's a desire for something

@ -1,6 +1,6 @@
--- jiff-0.1.15/Cargo.toml 1970-01-01T00:00:01+00:00 --- jiff-0.1.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.15/Cargo.toml 2024-12-09T14:41:20.406646+00:00 +++ jiff-0.1.16/Cargo.toml 2024-12-27T00:19:01.399220+00:00
@@ -131,46 +131,22 @@ @@ -142,8 +142,6 @@
"tzdb-zoneinfo", "tzdb-zoneinfo",
] ]
js = [ js = [
@ -9,7 +9,8 @@
] ]
logging = ["dep:log"] logging = ["dep:log"]
serde = ["dep:serde"] serde = ["dep:serde"]
std = ["alloc"] @@ -153,38 +151,16 @@
]
tz-system = [ tz-system = [
"std", "std",
- "dep:windows-sys", - "dep:windows-sys",

@ -1,15 +1,16 @@
--- jiff-0.1.15/Cargo.toml 1970-01-01T00:00:01+00:00 --- jiff-0.1.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.15/Cargo.toml 2024-12-09T14:41:20.408646+00:00 +++ jiff-0.1.16/Cargo.toml 2024-12-27T00:19:01.401220+00:00
@@ -85,7 +85,7 @@ @@ -113,9 +113,6 @@
features = ["serde"] [dev-dependencies.serde_json]
version = "1.0.117"
[dev-dependencies.chrono-tz] -[dev-dependencies.serde_yml]
-version = "0.9.0" -version = "0.0.12"
+version = ">=0.9,<0.11" -
[dev-dependencies.tabwriter]
version = "1.4.0"
[dev-dependencies.icu] @@ -161,6 +158,3 @@
version = "1.5.0"
@@ -147,6 +147,3 @@
] ]
tzdb-zoneinfo = ["std"] tzdb-zoneinfo = ["std"]

@ -5,7 +5,7 @@
%global crate jiff %global crate jiff
Name: rust-jiff Name: rust-jiff
Version: 0.1.15 Version: 0.1.16
Release: %autorelease Release: %autorelease
Summary: Date-time library that encourages you to jump into the pit of success Summary: Date-time library that encourages you to jump into the pit of success
@ -16,14 +16,18 @@ Source: %{crates_source}
Patch: jiff-fix-metadata-auto.diff Patch: jiff-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * Drop dev-dependency hifitime: not packaged, and only for doctests # * Drop dev-dependency hifitime: not packaged, and only for doctests
# * Relax chrono-tz dependency to allow building with 0.9 and 0.10: # * Drop dev-dependency serde_yml: not packaged; we have patched out the tests
# https://github.com/BurntSushi/jiff/pull/167 # that require it
Patch: jiff-fix-metadata.diff Patch: jiff-fix-metadata.diff
# * Downstream-only: Omit doctests that require hifitime. It is not worth # * Downstream-only: Omit doctests that require hifitime. It is not worth
# packaging it solely for a couple of tiny examples. # packaging it solely for a couple of tiny examples.
Patch10: 0001-Downstream-only-Omit-doctests-that-require-hifitime.patch Patch10: 0001-Downstream-only-Omit-doctests-that-require-hifitime.patch
# * Downstream-only: Omit doctests that require icu. # * Downstream-only: Omit doctests that require icu.
Patch11: 0001-Downstream-only-Omit-doctests-that-require-icu.patch Patch11: 0001-Downstream-only-Omit-doctests-that-require-icu.patch
# * Downstream-only: Omit tests that require serde_yml.
Patch12: 0001-Downstream-only-omit-tests-that-require-serde_yml.patch
# * Fix a small typo in CHANGELOG.md
Patch13: https://github.com/BurntSushi/jiff/pull/173.patch
# * EPEL9: Ignore doctests that require very recent Rust compilers # * EPEL9: Ignore doctests that require very recent Rust compilers
# * In this crate, doctests and examples (but not the lib and integration tests) # * In this crate, doctests and examples (but not the lib and integration tests)
# are allowed to use Rust features from versions newer than the MSRV. Its # are allowed to use Rust features from versions newer than the MSRV. Its

@ -20,8 +20,8 @@ cargo-toml-patch-comments = [
# target.'cfg(not(target_family = "wasm"))', manual patching is easier. # target.'cfg(not(target_family = "wasm"))', manual patching is easier.
"Drop dev-dependency hifitime: not packaged, and only for doctests", "Drop dev-dependency hifitime: not packaged, and only for doctests",
"""\ """\
Relax chrono-tz dependency to allow building with 0.9 and 0.10: \ Drop dev-dependency serde_yml: not packaged; we have patched out the tests \
https://github.com/BurntSushi/jiff/pull/167\ that require it\
""", """,
] ]
@ -44,6 +44,22 @@ comments = [
""", """,
] ]
[[package.extra-patches]]
number = 12
file = "0001-Downstream-only-omit-tests-that-require-serde_yml.patch"
comments = [
"""\
Downstream-only: Omit tests that require serde_yml.\
""",
]
[[package.extra-patches]]
number = 13
file = "https://github.com/BurntSushi/jiff/pull/173.patch"
comments = [
"Fix a small typo in CHANGELOG.md",
]
[[package.extra-patches]] [[package.extra-patches]]
number = 1009 number = 1009
file = "0001-EPEL9-Ignore-doctests-that-require-very-recent-Rust-.patch" file = "0001-EPEL9-Ignore-doctests-that-require-very-recent-Rust-.patch"

@ -1 +1 @@
SHA512 (jiff-0.1.15.crate) = 42f173c8f9b819c400325c9c50aa5a0808617d900a97bb3f61d55cdffc0a013cff356ae61ab15a39917bc366221968e1479ca072330af8bd145710195c47404c SHA512 (jiff-0.1.16.crate) = e83ba1e75ad848666f3ed68c14c1f9a82cdb92360add760ec259837c562e487a830766981026ee7d537b701478b3713f80f52d8f996ade4eb1a126be126f200e

Loading…
Cancel
Save