parent
aed1047f23
commit
9d9498eae4
@ -0,0 +1 @@
|
|||||||
|
/iso8601-0.2.0.crate
|
@ -0,0 +1,12 @@
|
|||||||
|
--- iso8601-0.2.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ iso8601-0.2.0/Cargo.toml 2017-11-20T16:18:15.776636+01:00
|
||||||
|
@@ -20,9 +20,6 @@
|
||||||
|
readme = "README.md"
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/badboy/iso8601"
|
||||||
|
-[dependencies.clippy]
|
||||||
|
-version = ">0.0.0"
|
||||||
|
-optional = true
|
||||||
|
|
||||||
|
[dependencies.nom]
|
||||||
|
version = "3.2"
|
@ -0,0 +1,61 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate iso8601
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Parsing ISO8601 dates using nom
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/iso8601
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No clippy
|
||||||
|
Patch0: iso8601-0.2.0-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(nom) >= 3.2.0 with crate(nom) < 4.0.0)
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Parsing ISO8601 dates using nom.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/Makefile
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Nov 20 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue