Initial import (#1976248)

epel9
Olivier Lemasle 4 years ago
parent 6a62383e44
commit d909fa9245

1
.gitignore vendored

@ -0,0 +1 @@
/io-lifetimes-0.2.0.crate

@ -0,0 +1,15 @@
--- io-lifetimes-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ io-lifetimes-0.2.0/Cargo.toml 2021-06-25T15:41:57.787507+00:00
@@ -44,11 +44,8 @@
features = ["io-std", "fs", "net", "process"]
optional = true
[build-dependencies.rustc_version]
-version = "0.4.0"
+version = "0.3.3"
[target."cfg(not(windows))".dependencies.libc]
version = "0.2.96"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["handleapi", "std", "winsock2"]
[badges.maintenance]
status = "actively-developed"

@ -0,0 +1,141 @@
# Generated by rust2rpm 17
%bcond_without check
%global debug_package %{nil}
%global crate io-lifetimes
Name: rust-%{crate}
Version: 0.2.0
Release: 1%{?dist}
Summary: Low-level I/O ownership and borrowing library
# Upstream license specification: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
License: ASL 2.0 with exceptions or ASL 2.0 or MIT
URL: https://crates.io/crates/io-lifetimes
Source: %{crates_source}
# Initial patched metadata
# - Remove windows-only dependency
# - Use packaged version of rustc_version
Patch0: io-lifetimes-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand:
Low-level I/O ownership and borrowing library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%doc README.md
%doc CODE_OF_CONDUCT.md ORG_CODE_OF_CONDUCT.md
%license LICENSE-APACHE LICENSE-MIT COPYRIGHT
%license LICENSE-Apache-2.0_WITH_LLVM-exception
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+async-std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-std-devel %{_description}
This package contains library source intended for building other packages
which use "async-std" feature of "%{crate}" crate.
%files -n %{name}+async-std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+mio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mio-devel %{_description}
This package contains library source intended for building other packages
which use "mio" feature of "%{crate}" crate.
%files -n %{name}+mio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os_pipe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os_pipe-devel %{_description}
This package contains library source intended for building other packages
which use "os_pipe" feature of "%{crate}" crate.
%files -n %{name}+os_pipe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+socket2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+socket2-devel %{_description}
This package contains library source intended for building other packages
which use "socket2" feature of "%{crate}" crate.
%files -n %{name}+socket2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages
which use "tokio" feature of "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Jun 25 17:23:36 CEST 2021 Olivier Lemasle <o.lemasle@gmail.com> - 0.2.0-1
- Initial package

@ -0,0 +1 @@
SHA512 (io-lifetimes-0.2.0.crate) = a7c8821478d2180ce748958b2b4debd51a057f1d9a3ad1ac0b909e6e799f23bee87c92c87addf2f62da93a07fb699e9837aebe61a699f2800b825abaf733b379
Loading…
Cancel
Save