Update to version 0.7.4; Fixes RHBZ#2094062

epel9
Fabio Valentini 2 years ago
parent ba237281c2
commit 90acf4fca8
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/io-lifetimes-0.4.3.crate /io-lifetimes-0.4.3.crate
/io-lifetimes-0.4.4.crate /io-lifetimes-0.4.4.crate
/io-lifetimes-0.5.3.crate /io-lifetimes-0.5.3.crate
/io-lifetimes-0.7.4.crate

@ -0,0 +1,25 @@
--- io-lifetimes-0.7.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.7.4/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -42,7 +42,6 @@
[features]
close = [
"libc",
- "windows-sys",
]
default = ["close"]
@@ -80,14 +79,3 @@
version = "0.2.96"
optional = true
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.36.0"
-features = [
- "Win32_Foundation",
- "Win32_Storage_FileSystem",
- "Win32_Networking_WinSock",
- "Win32_Security",
- "Win32_System_IO",
- "Win32_System_Threading",
-]
-optional = true

@ -1,19 +0,0 @@
--- io-lifetimes-0.5.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.5.3/Cargo.toml 2022-04-12T09:48:03.245108+00:00
@@ -44,7 +44,7 @@
optional = true
[features]
-close = ["libc", "winapi"]
+close = ["libc"]
default = ["close"]
[target."cfg(not(target_os = \"wasi\"))".dependencies.os_pipe]
version = "1.0.0"
@@ -52,7 +52,3 @@
[target."cfg(not(windows))".dependencies.libc]
version = "0.2.96"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["handleapi", "std", "winsock2"]
-optional = true

@ -1,21 +1,19 @@
# Generated by rust2rpm 21 # Generated by rust2rpm 22
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate io-lifetimes %global crate io-lifetimes
Name: rust-%{crate} Name: rust-io-lifetimes
Version: 0.5.3 Version: 0.7.4
Release: %autorelease Release: %autorelease
Summary: Low-level I/O ownership and borrowing library Summary: Low-level I/O ownership and borrowing library
# Upstream license specification: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
License: ASL 2.0 or MIT
URL: https://crates.io/crates/io-lifetimes URL: https://crates.io/crates/io-lifetimes
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
# * drop windows-specific dependencies Patch: io-lifetimes-fix-metadata-auto.diff
Patch0: io-lifetimes-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -40,6 +38,8 @@ use the "%{crate}" crate.
%license %{crate_instdir}/LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception %license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception
%license %{crate_instdir}/LICENSE-MIT %license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/ORG_CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md %doc %{crate_instdir}/README.md
%{crate_instdir}/ %{crate_instdir}/

@ -1 +1 @@
SHA512 (io-lifetimes-0.5.3.crate) = 8fdb7b785aa9ad9ad256f3d5dd9e258ea6d6f3fa4c0c47326624356467ae137f7bcc64582ba94ab008fe3e0ab4279b4de3c741fe0b1b161d8fe635462f6cd265 SHA512 (io-lifetimes-0.7.4.crate) = a9c1a852ed7834d49a9f0e4f8d6623ee783b796228870ab8bf7c7e4e20417b9bc62fd08bfdacc0b410f92eeafe6e56247409ceec9475cfaabc0a56d4380a445f

Loading…
Cancel
Save