Update to version 0.4.4

epel9
Fabio Valentini 3 years ago
parent 68e1b00fa9
commit 09ece78345
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/io-lifetimes-0.2.0.crate
/io-lifetimes-0.3.1.crate
/io-lifetimes-0.4.3.crate
/io-lifetimes-0.4.4.crate

@ -1,3 +0,0 @@
[DEFAULT]
unwanted-features =
fs-err

@ -1,20 +1,5 @@
--- io-lifetimes-0.4.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.4.3/Cargo.toml 2021-11-28T23:11:43.975590+00:00
@@ -30,12 +30,12 @@
optional = true
[dependencies.mio]
-version = "0.8.0"
+version = "0.7.14"
features = ["net", "os-ext"]
optional = true
[dependencies.os_pipe]
-version = "1.0.0"
+version = "0.9.2"
optional = true
[dependencies.socket2]
--- io-lifetimes-0.4.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-0.4.4/Cargo.toml 2022-02-03T13:56:41.549623+00:00
@@ -53,8 +53,5 @@
[target."cfg(not(windows))".dependencies.libc]
version = "0.2.96"

@ -1,27 +1,23 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate io-lifetimes
Name: rust-%{crate}
Version: 0.4.3
Version: 0.4.4
Release: %autorelease
Summary: Low-level I/O ownership and borrowing library
# Upstream license specification: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
License: ASL 2.0 with exceptions or ASL 2.0 or MIT
License: ASL 2.0 or MIT
URL: https://crates.io/crates/io-lifetimes
Source: %{crates_source}
# Initial patched metadata
# - Remove windows-only dependency
# - Downgrade dependencies "mio" and "os_pipe"
# * drop windows-specific dependencies
Patch0: io-lifetimes-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -36,14 +32,12 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license COPYRIGHT LICENSE-APACHE LICENSE-Apache-2.0_WITH_LLVM-exception LICENSE-MIT
%doc README.md
%doc CODE_OF_CONDUCT.md ORG_CODE_OF_CONDUCT.md
%license LICENSE-APACHE LICENSE-MIT COPYRIGHT
%license LICENSE-Apache-2.0_WITH_LLVM-exception
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
@ -52,8 +46,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -64,8 +58,8 @@ BuildArch: noarch
%description -n %{name}+async-std-devel %{_description}
This package contains library source intended for building other packages
which use "async-std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "async-std" feature of the "%{crate}" crate.
%files -n %{name}+async-std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -76,20 +70,32 @@ BuildArch: noarch
%description -n %{name}+close-devel %{_description}
This package contains library source intended for building other packages
which use "close" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "close" feature of the "%{crate}" crate.
%files -n %{name}+close-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+fs-err-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fs-err-devel %{_description}
This package contains library source intended for building other packages which
use the "fs-err" feature of the "%{crate}" crate.
%files -n %{name}+fs-err-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -100,8 +106,8 @@ BuildArch: noarch
%description -n %{name}+mio-devel %{_description}
This package contains library source intended for building other packages
which use "mio" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "mio" feature of the "%{crate}" crate.
%files -n %{name}+mio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -112,8 +118,8 @@ BuildArch: noarch
%description -n %{name}+os_pipe-devel %{_description}
This package contains library source intended for building other packages
which use "os_pipe" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "os_pipe" feature of the "%{crate}" crate.
%files -n %{name}+os_pipe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -124,8 +130,8 @@ BuildArch: noarch
%description -n %{name}+socket2-devel %{_description}
This package contains library source intended for building other packages
which use "socket2" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "socket2" feature of the "%{crate}" crate.
%files -n %{name}+socket2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -136,8 +142,8 @@ BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages
which use "tokio" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (io-lifetimes-0.4.3.crate) = 6c91c168afafac8d64e53b208522ebb841ec66f81013c2e015a173c716bac105483248e3405fbe19c7a4532ed4e999493b67fd3fbd10ae8fbbc6a2cd9ea7e96f
SHA512 (io-lifetimes-0.4.4.crate) = 0ac4696791310c51a7f2e8df4fb98e6293c089fae8960912e4d3cd6584467db0997d7e128680e5544367dd6b20b1e9091c13df95abf63136c2412655b61a010a

Loading…
Cancel
Save