parent
68d7790d2a
commit
ef90e025f1
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/indicatif-0.15.0.crate
|
@ -0,0 +1,58 @@
|
|||||||
|
From 5d9ef658048057348644bf4ddc85543197f31123 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Tue, 20 Jul 2021 15:44:44 +0200
|
||||||
|
Subject: [PATCH] port to number_prefix 0.4
|
||||||
|
|
||||||
|
---
|
||||||
|
src/format.rs | 14 +++++++-------
|
||||||
|
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/format.rs b/src/format.rs
|
||||||
|
index 99eb0c4..7333248 100644
|
||||||
|
--- a/src/format.rs
|
||||||
|
+++ b/src/format.rs
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
use std::fmt;
|
||||||
|
use std::time::Duration;
|
||||||
|
|
||||||
|
-use number_prefix::{NumberPrefix, PrefixNames, Prefixed, Standalone};
|
||||||
|
+use number_prefix::NumberPrefix;
|
||||||
|
|
||||||
|
/// Wraps an std duration for human basic formatting.
|
||||||
|
#[derive(Debug)]
|
||||||
|
@@ -77,8 +77,8 @@ impl fmt::Display for HumanDuration {
|
||||||
|
impl fmt::Display for HumanBytes {
|
||||||
|
fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
|
||||||
|
match NumberPrefix::binary(self.0 as f64) {
|
||||||
|
- Standalone(number) => write!(f, "{:.0}B", number),
|
||||||
|
- Prefixed(prefix, number) => write!(
|
||||||
|
+ NumberPrefix::Standalone(number) => write!(f, "{:.0}B", number),
|
||||||
|
+ NumberPrefix::Prefixed(prefix, number) => write!(
|
||||||
|
f,
|
||||||
|
"{:.2}{}B",
|
||||||
|
number,
|
||||||
|
@@ -91,8 +91,8 @@ impl fmt::Display for HumanBytes {
|
||||||
|
impl fmt::Display for DecimalBytes {
|
||||||
|
fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
|
||||||
|
match NumberPrefix::decimal(self.0 as f64) {
|
||||||
|
- Standalone(number) => write!(f, "{:.0}B", number),
|
||||||
|
- Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
|
||||||
|
+ NumberPrefix::Standalone(number) => write!(f, "{:.0}B", number),
|
||||||
|
+ NumberPrefix::Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -100,8 +100,8 @@ impl fmt::Display for DecimalBytes {
|
||||||
|
impl fmt::Display for BinaryBytes {
|
||||||
|
fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
|
||||||
|
match NumberPrefix::binary(self.0 as f64) {
|
||||||
|
- Standalone(number) => write!(f, "{:.0}B", number),
|
||||||
|
- Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
|
||||||
|
+ NumberPrefix::Standalone(number) => write!(f, "{:.0}B", number),
|
||||||
|
+ NumberPrefix::Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- indicatif-0.15.0/Cargo.toml 2020-06-14T22:23:13+00:00
|
||||||
|
+++ indicatif-0.15.0/Cargo.toml 2022-01-12T13:44:11.842153+00:00
|
||||||
|
@@ -29,7 +29,7 @@
|
||||||
|
version = "1.0"
|
||||||
|
|
||||||
|
[dependencies.number_prefix]
|
||||||
|
-version = "0.3"
|
||||||
|
+version = "0.4"
|
||||||
|
|
||||||
|
[dependencies.rayon]
|
||||||
|
version = "1.0"
|
@ -0,0 +1,137 @@
|
|||||||
|
# Generated by rust2rpm 20
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate indicatif
|
||||||
|
|
||||||
|
Name: rust-%{crate}0.15
|
||||||
|
Version: 0.15.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Progress bar and cli reporting library for Rust
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/indicatif
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * bump number_prefix from 0.3 to 0.4
|
||||||
|
Patch0: indicatif-fix-metadata.diff
|
||||||
|
# * port to number_prefix 0.4:
|
||||||
|
# https://github.com/mitsuhiko/indicatif/commit/c3403b8
|
||||||
|
Patch1: 0001-port-to-number_prefix-0.4.patch
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Progress bar and cli reporting library for Rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+improved_unicode-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+improved_unicode-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "improved_unicode" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+improved_unicode-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+rayon-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+rayon-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "rayon" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+rayon-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-segmentation-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-segmentation-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-segmentation" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-segmentation-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-width-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-width-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-width" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-width-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+with_rayon-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+with_rayon-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "with_rayon" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+with_rayon-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue