parent
5c8d77e406
commit
e24118537e
@ -1 +1,2 @@
|
|||||||
/indicatif-0.11.0.crate
|
/indicatif-0.11.0.crate
|
||||||
|
/indicatif-0.13.0.crate
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
From bb65a6667a038469e17ac73e9e91d704def8fb76 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael <5672750+mibac138@users.noreply.github.com>
|
|
||||||
Date: Mon, 6 May 2019 00:44:53 +0200
|
|
||||||
Subject: [PATCH] Update number_prefix to 0.3 (#93)
|
|
||||||
|
|
||||||
---
|
|
||||||
src/format.rs | 8 ++++----
|
|
||||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/format.rs b/src/format.rs
|
|
||||||
index ca0ed22..82ea3b8 100644
|
|
||||||
--- a/src/format.rs
|
|
||||||
+++ b/src/format.rs
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
use std::fmt;
|
|
||||||
use std::time::Duration;
|
|
||||||
|
|
||||||
-use number_prefix::{binary_prefix, decimal_prefix, PrefixNames, Prefixed, Standalone};
|
|
||||||
+use number_prefix::{NumberPrefix, PrefixNames, Prefixed, Standalone};
|
|
||||||
|
|
||||||
/// Wraps an std duration for human basic formatting.
|
|
||||||
#[derive(Debug)]
|
|
||||||
@@ -76,7 +76,7 @@ impl fmt::Display for HumanDuration {
|
|
||||||
|
|
||||||
impl fmt::Display for HumanBytes {
|
|
||||||
fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
|
|
||||||
- match binary_prefix(self.0 as f64) {
|
|
||||||
+ match NumberPrefix::binary(self.0 as f64) {
|
|
||||||
Standalone(number) => write!(f, "{:.0}B", number),
|
|
||||||
Prefixed(prefix, number) => write!(
|
|
||||||
f,
|
|
||||||
@@ -90,7 +90,7 @@ impl fmt::Display for HumanBytes {
|
|
||||||
|
|
||||||
impl fmt::Display for DecimalBytes {
|
|
||||||
fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
|
|
||||||
- match decimal_prefix(self.0 as f64) {
|
|
||||||
+ match NumberPrefix::decimal(self.0 as f64) {
|
|
||||||
Standalone(number) => write!(f, "{:.0}B", number),
|
|
||||||
Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
|
|
||||||
}
|
|
||||||
@@ -99,7 +99,7 @@ impl fmt::Display for DecimalBytes {
|
|
||||||
|
|
||||||
impl fmt::Display for BinaryBytes {
|
|
||||||
fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
|
|
||||||
- match binary_prefix(self.0 as f64) {
|
|
||||||
+ match NumberPrefix::binary(self.0 as f64) {
|
|
||||||
Standalone(number) => write!(f, "{:.0}B", number),
|
|
||||||
Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
--- indicatif-0.11.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
||||||
+++ indicatif-0.11.0/Cargo.toml 2019-05-07T12:30:02.106383+00:00
|
|
||||||
@@ -28,7 +28,7 @@
|
|
||||||
version = "1"
|
|
||||||
|
|
||||||
[dependencies.number_prefix]
|
|
||||||
-version = "0.2"
|
|
||||||
+version = "0.3"
|
|
||||||
|
|
||||||
[dependencies.parking_lot]
|
|
||||||
version = "0"
|
|
@ -1 +1 @@
|
|||||||
SHA512 (indicatif-0.11.0.crate) = 68c45d5a7ae1179faaf683bd006e01df5c074ffdc205f533f98b03b99dd1b0242f61dafa16448a3c481c3a815d317df66d5be4ef078e5b3abac34f7f091a4901
|
SHA512 (indicatif-0.13.0.crate) = 840cbb29d6d5171afb41d3d1ff9602cec82686919f092b3340d246abd4720fbd15d77a5c1fb1673a5b86b3c4f90f49289cff622d3145d639dc3b1affea106f98
|
||||||
|
Loading…
Reference in new issue