Update to 0.13.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent 5c8d77e406
commit e24118537e
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/indicatif-0.11.0.crate /indicatif-0.11.0.crate
/indicatif-0.13.0.crate

@ -1,52 +0,0 @@
From bb65a6667a038469e17ac73e9e91d704def8fb76 Mon Sep 17 00:00:00 2001
From: Michael <5672750+mibac138@users.noreply.github.com>
Date: Mon, 6 May 2019 00:44:53 +0200
Subject: [PATCH] Update number_prefix to 0.3 (#93)
---
src/format.rs | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/format.rs b/src/format.rs
index ca0ed22..82ea3b8 100644
--- a/src/format.rs
+++ b/src/format.rs
@@ -1,7 +1,7 @@
use std::fmt;
use std::time::Duration;
-use number_prefix::{binary_prefix, decimal_prefix, PrefixNames, Prefixed, Standalone};
+use number_prefix::{NumberPrefix, PrefixNames, Prefixed, Standalone};
/// Wraps an std duration for human basic formatting.
#[derive(Debug)]
@@ -76,7 +76,7 @@ impl fmt::Display for HumanDuration {
impl fmt::Display for HumanBytes {
fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
- match binary_prefix(self.0 as f64) {
+ match NumberPrefix::binary(self.0 as f64) {
Standalone(number) => write!(f, "{:.0}B", number),
Prefixed(prefix, number) => write!(
f,
@@ -90,7 +90,7 @@ impl fmt::Display for HumanBytes {
impl fmt::Display for DecimalBytes {
fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
- match decimal_prefix(self.0 as f64) {
+ match NumberPrefix::decimal(self.0 as f64) {
Standalone(number) => write!(f, "{:.0}B", number),
Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
}
@@ -99,7 +99,7 @@ impl fmt::Display for DecimalBytes {
impl fmt::Display for BinaryBytes {
fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
- match binary_prefix(self.0 as f64) {
+ match NumberPrefix::binary(self.0 as f64) {
Standalone(number) => write!(f, "{:.0}B", number),
Prefixed(prefix, number) => write!(f, "{:.2}{}B", number, prefix),
}
--
2.21.0

@ -1,11 +0,0 @@
--- indicatif-0.11.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ indicatif-0.11.0/Cargo.toml 2019-05-07T12:30:02.106383+00:00
@@ -28,7 +28,7 @@
version = "1"
[dependencies.number_prefix]
-version = "0.2"
+version = "0.3"
[dependencies.parking_lot]
version = "0"

@ -1,23 +1,18 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 11
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate indicatif %global crate indicatif
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.11.0 Version: 0.13.0
Release: 6%{?dist} Release: 1%{?dist}
Summary: Progress bar and cli reporting library for Rust Summary: Progress bar and cli reporting library for Rust
# Upstream license specification: MIT # Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/indicatif URL: https://crates.io/crates/indicatif
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * Update number_prefix to 0.3, https://github.com/mitsuhiko/indicatif/commit/bb65a6667a038469e17ac73e9e91d704def8fb76
Patch0: indicatif-fix-metadata.diff
# Make it work with new number_prefix
Patch1: 0001-Update-number_prefix-to-0.3-93.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -57,6 +52,30 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+rayon-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages
which use "rayon" feature of "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+with_rayon-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+with_rayon-devel %{_description}
This package contains library source intended for building other packages
which use "with_rayon" feature of "%{crate}" crate.
%files -n %{name}+with_rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -76,6 +95,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Fri Dec 06 17:29:48 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.0-1
- Update to 0.13.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-6 * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (indicatif-0.11.0.crate) = 68c45d5a7ae1179faaf683bd006e01df5c074ffdc205f533f98b03b99dd1b0242f61dafa16448a3c481c3a815d317df66d5be4ef078e5b3abac34f7f091a4901 SHA512 (indicatif-0.13.0.crate) = 840cbb29d6d5171afb41d3d1ff9602cec82686919f092b3340d246abd4720fbd15d77a5c1fb1673a5b86b3c4f90f49289cff622d3145d639dc3b1affea106f98

Loading…
Cancel
Save