Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 3f60c84d32
commit c5f547010b
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,51 @@
From 55838d42ac6217a5b9ad87ebe884f7a2c9902fc0 Mon Sep 17 00:00:00 2001
From: bluss <bluss@users.noreply.github.com>
Date: Sat, 24 Nov 2018 23:26:39 +0100
Subject: [PATCH] MAINT: Update quickcheck to 0.7 and rand to 0.5
---
benches/bench.rs | 7 ++++++-
tests/quick.rs | 2 ++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/benches/bench.rs b/benches/bench.rs
index b3e9915..20eedb6 100644
--- a/benches/bench.rs
+++ b/benches/bench.rs
@@ -20,7 +20,12 @@ use indexmap::IndexMap;
use std::collections::HashMap;
use std::iter::FromIterator;
-use rand::{weak_rng, Rng};
+use rand::{thread_rng, Rng, SeedableRng};
+use rand::rngs::SmallRng;
+
+fn weak_rng() -> SmallRng {
+ SmallRng::from_rng(thread_rng()).unwrap()
+}
#[bench]
fn new_hashmap(b: &mut Bencher) {
diff --git a/tests/quick.rs b/tests/quick.rs
index 14f267c..413637d 100644
--- a/tests/quick.rs
+++ b/tests/quick.rs
@@ -3,6 +3,7 @@ extern crate indexmap;
extern crate itertools;
#[macro_use]
extern crate quickcheck;
+extern crate rand;
extern crate fnv;
@@ -11,6 +12,7 @@ use itertools::Itertools;
use quickcheck::Arbitrary;
use quickcheck::Gen;
+use rand::Rng;
use fnv::FnvHasher;
use std::hash::{BuildHasher, BuildHasherDefault};
--
2.22.0

@ -0,0 +1,23 @@
--- indexmap-1.0.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ indexmap-1.0.2/Cargo.toml 2019-06-22T07:41:34.144641+00:00
@@ -37,17 +37,17 @@
version = "1.0"
[dev-dependencies.itertools]
-version = "0.7.0"
+version = "0.8.0"
[dev-dependencies.lazy_static]
version = "1"
[dev-dependencies.quickcheck]
-version = "0.6"
+version = "0.8"
default-features = false
[dev-dependencies.rand]
-version = "0.4"
+version = "0.6"
[dev-dependencies.serde_test]
version = "1.0.5"

@ -1,46 +1,42 @@
# Generated by rust2rpm # Generated by rust2rpm 10
# Tests are run in infrastructure %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate indexmap %global crate indexmap
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.0.2 Version: 1.0.2
Release: 3%{?dist} Release: 4%{?dist}
Summary: Hash table with consistent order and fast iteration Summary: Hash table with consistent order and fast iteration
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/indexmap URL: https://crates.io/crates/indexmap
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata
# * Update itertools to 0.8
# * Update rand to 0.6, quickcheck to 0.8, https://github.com/bluss/indexmap/pull/85
Patch0: indexmap-fix-metadata.diff
# Finish rand update
Patch0001: 0001-MAINT-Update-quickcheck-to-0.7-and-rand-to-0.5.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(fnv/default) >= 1.0.0 with crate(fnv/default) < 2.0.0)
BuildRequires: (crate(itertools/default) >= 0.7.0 with crate(itertools/default) < 0.8.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(quickcheck) >= 0.6.0 with crate(quickcheck) < 0.7.0)
BuildRequires: (crate(rand/default) >= 0.4.0 with crate(rand/default) < 0.5.0)
BuildRequires: (crate(serde_test/default) >= 1.0.5 with crate(serde_test/default) < 2.0.0)
%endif
%global _description \ %global _description %{expand:
A hash table with consistent order and fast iteration.\ Hash table with consistent order and fast iteration.
\ The indexmap is a hash
The indexmap is a hash table\ table where the iteration order of the key-value pairs is independent of the
where the iteration order of the key-value pairs is\ hash values of the keys. It has the usual hash table functionality, it
independent of the hash values of the keys.\ preserves insertion order except after removals, and it allows lookup of its
It has the usual hash table functionality,\ elements by either hash table key or numerical index. A corresponding hash set
it preservesinsertion order except after removals,\ type is also provided.
and it allows lookup of its elements by either hash table key\ This crate was initially published under the name
or numerical index. A corresponding hash set type is also provided.\ ordermap, but it was renamed to indexmap.}
\
This crate was initially published under the name ordermap,\
but it was renamed to indexmap.
%description %{_description} %description %{_description}
@ -94,10 +90,37 @@ which use "serde-1" feature of "%{crate}" crate.
%files -n %{name}+serde-1-devel %files -n %{name}+serde-1-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+test_debug-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test_debug-devel %{_description}
This package contains library source intended for building other packages
which use "test_debug" feature of "%{crate}" crate.
%files -n %{name}+test_debug-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+test_low_transition_point-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test_low_transition_point-devel %{_description}
This package contains library source intended for building other packages
which use "test_low_transition_point" feature of "%{crate}" crate.
%files -n %{name}+test_low_transition_point-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build
@ -110,6 +133,9 @@ which use "serde-1" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sat Jun 22 09:41:34 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.2-4
- Regenerate
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-3 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

Loading…
Cancel
Save