Update to 1.3.1

epel9
Josh Stone 5 years ago
parent e10fe447f4
commit 314395ffa8

1
.gitignore vendored

@ -5,3 +5,4 @@
/indexmap-1.1.0.crate /indexmap-1.1.0.crate
/indexmap-1.2.0.crate /indexmap-1.2.0.crate
/indexmap-1.3.0.crate /indexmap-1.3.0.crate
/indexmap-1.3.1.crate

@ -1,16 +1,20 @@
--- indexmap-1.2.0/Cargo.toml 1970-01-01T00:00:00+00:00 --- indexmap-1.3.1/Cargo.toml 2020-01-15T19:24:16+00:00
+++ indexmap-1.2.0/Cargo.toml 2019-09-14T21:02:30.979815+00:00 +++ indexmap-1.3.1/Cargo.toml 2020-01-15T19:52:40.563540+00:00
@@ -48,11 +48,11 @@ @@ -37,8 +37,8 @@
version = "1.3"
[dev-dependencies.quickcheck] [dev-dependencies]
-version = "0.8" itertools = "0.8"
+version = "0.9" -rand = "0.6"
default-features = false -quickcheck = { version = "0.8", default-features = false }
+rand = "0.7"
+quickcheck = { version = "0.9", default-features = false }
fnv = "1.0"
lazy_static = "1.3"
serde_test = "1.0.99"
@@ -60,6 +60,3 @@
[dev-dependencies.rand] [package.metadata.docs.rs]
-version = "0.6" features = ["serde-1", "rayon"]
+version = "0.7" -
-[workspace]
[dev-dependencies.serde_test] -members = ["test-nostd"]
version = "1.0.99"

@ -1,11 +1,11 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 13
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate indexmap %global crate indexmap
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.3.0 Version: 1.3.1
Release: 1%{?dist} Release: 1%{?dist}
Summary: Hash table with consistent order and fast iteration Summary: Hash table with consistent order and fast iteration
@ -50,7 +50,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license LICENSE-APACHE LICENSE-MIT
%doc README.rst %doc README.rst
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -62,7 +62,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rayon-devel %package -n %{name}+rayon-devel
Summary: %{summary} Summary: %{summary}
@ -74,7 +74,7 @@ This package contains library source intended for building other packages
which use "rayon" feature of "%{crate}" crate. which use "rayon" feature of "%{crate}" crate.
%files -n %{name}+rayon-devel %files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -86,7 +86,7 @@ This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate. which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-1-devel %package -n %{name}+serde-1-devel
Summary: %{summary} Summary: %{summary}
@ -98,7 +98,7 @@ This package contains library source intended for building other packages
which use "serde-1" feature of "%{crate}" crate. which use "serde-1" feature of "%{crate}" crate.
%files -n %{name}+serde-1-devel %files -n %{name}+serde-1-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+test_debug-devel %package -n %{name}+test_debug-devel
Summary: %{summary} Summary: %{summary}
@ -110,7 +110,7 @@ This package contains library source intended for building other packages
which use "test_debug" feature of "%{crate}" crate. which use "test_debug" feature of "%{crate}" crate.
%files -n %{name}+test_debug-devel %files -n %{name}+test_debug-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+test_low_transition_point-devel %package -n %{name}+test_low_transition_point-devel
Summary: %{summary} Summary: %{summary}
@ -122,7 +122,7 @@ This package contains library source intended for building other packages
which use "test_low_transition_point" feature of "%{crate}" crate. which use "test_low_transition_point" feature of "%{crate}" crate.
%files -n %{name}+test_low_transition_point-devel %files -n %{name}+test_low_transition_point-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -143,6 +143,9 @@ which use "test_low_transition_point" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> - 1.3.1-1
- Update to 1.3.1
* Tue Nov 19 2019 Josh Stone <jistone@redhat.com> - 1.3.0-1 * Tue Nov 19 2019 Josh Stone <jistone@redhat.com> - 1.3.0-1
- Update to 1.3.0 - Update to 1.3.0

@ -1 +1 @@
SHA512 (indexmap-1.3.0.crate) = 41c933a78a5cd5e62aac2c4c8aaf20bd3fb394b9fa41fb9c59a69afa9b4039dfab82b3d1fb1b0c67f28f0cc7657cea6310db126dd4d84e3473d2c231fecc2331 SHA512 (indexmap-1.3.1.crate) = 1f102bf25ca31fdaabaa692ce7110c12b996c016b324f04d1c9ff1c4179426e0c6bee314ba91f2fc508f4e8b96e51b361aa42c7f0926afa1f6b1e499e734c15e

Loading…
Cancel
Save