Update to 1.1.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent 6e08c3ea43
commit 07630b0ced
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -2,3 +2,4 @@
/indexmap-1.0.0.crate
/indexmap-1.0.1.crate
/indexmap-1.0.2.crate
/indexmap-1.1.0.crate

@ -1,51 +0,0 @@
From 55838d42ac6217a5b9ad87ebe884f7a2c9902fc0 Mon Sep 17 00:00:00 2001
From: bluss <bluss@users.noreply.github.com>
Date: Sat, 24 Nov 2018 23:26:39 +0100
Subject: [PATCH] MAINT: Update quickcheck to 0.7 and rand to 0.5
---
benches/bench.rs | 7 ++++++-
tests/quick.rs | 2 ++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/benches/bench.rs b/benches/bench.rs
index b3e9915..20eedb6 100644
--- a/benches/bench.rs
+++ b/benches/bench.rs
@@ -20,7 +20,12 @@ use indexmap::IndexMap;
use std::collections::HashMap;
use std::iter::FromIterator;
-use rand::{weak_rng, Rng};
+use rand::{thread_rng, Rng, SeedableRng};
+use rand::rngs::SmallRng;
+
+fn weak_rng() -> SmallRng {
+ SmallRng::from_rng(thread_rng()).unwrap()
+}
#[bench]
fn new_hashmap(b: &mut Bencher) {
diff --git a/tests/quick.rs b/tests/quick.rs
index 14f267c..413637d 100644
--- a/tests/quick.rs
+++ b/tests/quick.rs
@@ -3,6 +3,7 @@ extern crate indexmap;
extern crate itertools;
#[macro_use]
extern crate quickcheck;
+extern crate rand;
extern crate fnv;
@@ -11,6 +12,7 @@ use itertools::Itertools;
use quickcheck::Arbitrary;
use quickcheck::Gen;
+use rand::Rng;
use fnv::FnvHasher;
use std::hash::{BuildHasher, BuildHasherDefault};
--
2.22.0

@ -1,23 +0,0 @@
--- indexmap-1.0.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ indexmap-1.0.2/Cargo.toml 2019-06-22T07:41:34.144641+00:00
@@ -37,17 +37,17 @@
version = "1.0"
[dev-dependencies.itertools]
-version = "0.7.0"
+version = "0.8.0"
[dev-dependencies.lazy_static]
version = "1"
[dev-dependencies.quickcheck]
-version = "0.6"
+version = "0.8"
default-features = false
[dev-dependencies.rand]
-version = "0.4"
+version = "0.6"
[dev-dependencies.serde_test]
version = "1.0.5"

@ -5,20 +5,14 @@
%global crate indexmap
Name: rust-%{crate}
Version: 1.0.2
Release: 5%{?dist}
Version: 1.1.0
Release: 1%{?dist}
Summary: Hash table with consistent order and fast iteration
# Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT
URL: https://crates.io/crates/indexmap
Source: %{crates_source}
# Initial patched metadata
# * Update itertools to 0.8
# * Update rand to 0.6, quickcheck to 0.8, https://github.com/bluss/indexmap/pull/85
Patch0: indexmap-fix-metadata.diff
# Finish rand update
Patch0001: 0001-MAINT-Update-quickcheck-to-0.7-and-rand-to-0.5.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -66,6 +60,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+rayon-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages
which use "rayon" feature of "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -133,6 +139,9 @@ which use "test_low_transition_point" feature of "%{crate}" crate.
%endif
%changelog
* Sun Sep 01 20:30:16 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.1.0-1
- Update to 1.1.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (indexmap-1.0.2.crate) = cfae9d222efcce9ab15c5a8368db2865fbdb6819b4fc317ca0aed55c32ea312b5c5ca13130d4aabf08af1803c34d465a1a1209dabbce37e7a1a911faf5cfcfe8
SHA512 (indexmap-1.1.0.crate) = d2f6616dcd4af033e70204141221acf1782bfc4784b526c35a369b6b2c09dea2d6ced6a012ba63ae5e8d0ef239e4518113a08f8312f1e21c04440ed782af9462

Loading…
Cancel
Save