Update to version 15.1.0; Fixes RHBZ#2080370

epel9
Fabio Valentini 3 years ago
parent bebd5348bc
commit 3413381264
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/im-rc-14.2.0.crate /im-rc-14.2.0.crate
/im-rc-14.3.0.crate /im-rc-14.3.0.crate
/im-rc-15.0.0.crate /im-rc-15.0.0.crate
/im-rc-15.1.0.crate

@ -1,45 +1,24 @@
--- im-rc-15.0.0/Cargo.toml 2020-05-15T19:00:18+00:00 --- im-rc-15.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ im-rc-15.0.0/Cargo.toml 2021-08-04T16:11:40.028148+00:00 +++ im-rc-15.1.0/Cargo.toml 2022-05-12T13:33:00.506027+00:00
@@ -29,33 +29,18 @@ @@ -62,10 +62,6 @@
version = "1"
optional = true
[lib] -[dependencies.refpool]
path = "./src/lib.rs"
-[dependencies.arbitrary]
-version = "0.4" -version = "0.4"
-optional = true
[dependencies.bitmaps]
version = "2"
-[dependencies.proptest]
-version = "0.9"
-optional = true
-
-[dependencies.quickcheck]
-version = "0.9"
-optional = true -optional = true
- -
[dependencies.rand_core] [dependencies.serde]
-version = "0.5.1"
+version = "0.6.3"
[dependencies.rand_xoshiro]
-version = "0.4"
+version = "0.6"
[dependencies.rayon]
version = "1" version = "1"
-optional = true
-
-[dependencies.refpool]
-version = "0.4"
optional = true optional = true
@@ -106,10 +102,6 @@
[dependencies.serde]
@@ -96,6 +81,5 @@
[features] [features]
debug = [] debug = []
-pool = ["refpool", "sized-chunks/refpool"] -pool = [
- "refpool",
- "sized-chunks/refpool",
-]
[badges.travis-ci] [badges.travis-ci]
repository = "bodil/im-rs" repository = "bodil/im-rs"

@ -1,12 +1,12 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 21
# * dev-dependencies are outdated # * missing dev-dependencies: metrohash
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate im-rc %global crate im-rc
Name: rust-%{crate} Name: rust-%{crate}
Version: 15.0.0 Version: 15.1.0
Release: %autorelease Release: %autorelease
Summary: Immutable collection datatypes (the fast but not thread safe version) Summary: Immutable collection datatypes (the fast but not thread safe version)
@ -15,18 +15,12 @@ License: MPLv2.0
URL: https://crates.io/crates/im-rc URL: https://crates.io/crates/im-rc
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * bump rand_core from 0.5.1 to 0.6.3 # * drop optional "pool" feature with missing "refpool" dependency
# * bump rand_xoshiro from 0.4 to 0.6
# * drop unused optional features with outdated or missing dependencies:
# arbitrary, proptest, quickcheck, pool/refpool
Patch0: im-rc-fix-metadata.diff Patch0: im-rc-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Immutable collection datatypes (the fast but not thread safe version).} Immutable collection datatypes (the fast but not thread safe version).}
@ -39,13 +33,15 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENCE.md %license %{crate_instdir}/LICENCE.md
%doc README.md CHANGELOG.md %doc %{crate_instdir}/CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -53,11 +49,23 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+debug-devel %package -n %{name}+debug-devel
Summary: %{summary} Summary: %{summary}
@ -65,11 +73,35 @@ BuildArch: noarch
%description -n %{name}+debug-devel %{_description} %description -n %{name}+debug-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "debug" feature of "%{crate}" crate. use the "debug" feature of the "%{crate}" crate.
%files -n %{name}+debug-devel %files -n %{name}+debug-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proptest-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+proptest-devel %{_description}
This package contains library source intended for building other packages which
use the "proptest" feature of the "%{crate}" crate.
%files -n %{name}+proptest-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quickcheck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quickcheck-devel %{_description}
This package contains library source intended for building other packages which
use the "quickcheck" feature of the "%{crate}" crate.
%files -n %{name}+quickcheck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rayon-devel %package -n %{name}+rayon-devel
Summary: %{summary} Summary: %{summary}
@ -77,11 +109,11 @@ BuildArch: noarch
%description -n %{name}+rayon-devel %{_description} %description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "rayon" feature of "%{crate}" crate. use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel %files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -89,11 +121,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (im-rc-15.0.0.crate) = 4be0ad2ef6272d39b3305dcf50c97836839c4917163c030ff2a950fb16deb4eed0d3026f09743479b344f9f688419449e8732923ee1146aa655ff5aae6279003 SHA512 (im-rc-15.1.0.crate) = 2825364dd8ddfa2a3623c3b507768b8602a3a17d0a9abd10b9ad20f4e7b6dbf5b35e928129bf0708ab29207e899e82f2285d24a7de2b55de3538b4123efc8bb9

Loading…
Cancel
Save