parent
f53df0eda8
commit
c6bc5528f6
@ -0,0 +1,43 @@
|
|||||||
|
From 9d500e76a0e1644c93b3869588f979e4440e74d6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon Sapin <simon.sapin@exyr.org>
|
||||||
|
Date: Sun, 25 Feb 2018 08:21:55 +0100
|
||||||
|
Subject: [PATCH] Update to rustc_test 0.3, unbreak tests on nightly-2018-02-25
|
||||||
|
|
||||||
|
Version 0.2 of the crates.io package `rustc_test` uses `test` as its
|
||||||
|
rustc crate name, shadowing the `test` crate from the standard library.
|
||||||
|
This made up subject to breaking changes to its private APIs:
|
||||||
|
|
||||||
|
https://travis-ci.org/SimonSapin/run-nightly/builds/345808272#L549
|
||||||
|
---
|
||||||
|
idna/tests/tests.rs | 2 +-
|
||||||
|
idna/tests/uts46.rs | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/idna/tests/tests.rs b/idna/tests/tests.rs
|
||||||
|
index 8ca2185..808ad6b 100644
|
||||||
|
--- a/idna/tests/tests.rs
|
||||||
|
+++ b/idna/tests/tests.rs
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
extern crate idna;
|
||||||
|
extern crate rustc_serialize;
|
||||||
|
-extern crate test;
|
||||||
|
+extern crate rustc_test as test;
|
||||||
|
|
||||||
|
mod punycode;
|
||||||
|
mod uts46;
|
||||||
|
diff --git a/idna/tests/uts46.rs b/idna/tests/uts46.rs
|
||||||
|
index ddc8af9..59ec1cd 100644
|
||||||
|
--- a/idna/tests/uts46.rs
|
||||||
|
+++ b/idna/tests/uts46.rs
|
||||||
|
@@ -108,7 +108,7 @@ fn unescape(input: &str) -> String {
|
||||||
|
let c2 = chars.next().unwrap().to_digit(16).unwrap();
|
||||||
|
let c3 = chars.next().unwrap().to_digit(16).unwrap();
|
||||||
|
let c4 = chars.next().unwrap().to_digit(16).unwrap();
|
||||||
|
- match char::from_u32((((c1 * 16 + c2) * 16 + c3) * 16 + c4))
|
||||||
|
+ match char::from_u32(((c1 * 16 + c2) * 16 + c3) * 16 + c4)
|
||||||
|
{
|
||||||
|
Some(c) => output.push(c),
|
||||||
|
None => { output.push_str(&format!("\\u{:X}{:X}{:X}{:X}",c1,c2,c3,c4)); }
|
||||||
|
--
|
||||||
|
2.16.2
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- idna-0.1.4/Cargo.toml 2017-07-13T18:21:49+02:00
|
||||||
|
+++ idna-0.1.4/Cargo.toml 2018-03-13T12:21:46.452973+01:00
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
name = "unit"
|
||||||
|
|
||||||
|
[dev-dependencies]
|
||||||
|
-rustc-test = "0.2"
|
||||||
|
+rustc-test = "0.3"
|
||||||
|
rustc-serialize = "0.3"
|
||||||
|
|
||||||
|
[dependencies]
|
Loading…
Reference in new issue