Adapt to new packaging

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 84538d1454
commit 3aa0898114
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,43 +0,0 @@
From 9d500e76a0e1644c93b3869588f979e4440e74d6 Mon Sep 17 00:00:00 2001
From: Simon Sapin <simon.sapin@exyr.org>
Date: Sun, 25 Feb 2018 08:21:55 +0100
Subject: [PATCH] Update to rustc_test 0.3, unbreak tests on nightly-2018-02-25
Version 0.2 of the crates.io package `rustc_test` uses `test` as its
rustc crate name, shadowing the `test` crate from the standard library.
This made up subject to breaking changes to its private APIs:
https://travis-ci.org/SimonSapin/run-nightly/builds/345808272#L549
---
idna/tests/tests.rs | 2 +-
idna/tests/uts46.rs | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/idna/tests/tests.rs b/idna/tests/tests.rs
index 8ca2185..808ad6b 100644
--- a/idna/tests/tests.rs
+++ b/idna/tests/tests.rs
@@ -1,6 +1,6 @@
extern crate idna;
extern crate rustc_serialize;
-extern crate test;
+extern crate rustc_test as test;
mod punycode;
mod uts46;
diff --git a/idna/tests/uts46.rs b/idna/tests/uts46.rs
index ddc8af9..59ec1cd 100644
--- a/idna/tests/uts46.rs
+++ b/idna/tests/uts46.rs
@@ -108,7 +108,7 @@ fn unescape(input: &str) -> String {
let c2 = chars.next().unwrap().to_digit(16).unwrap();
let c3 = chars.next().unwrap().to_digit(16).unwrap();
let c4 = chars.next().unwrap().to_digit(16).unwrap();
- match char::from_u32((((c1 * 16 + c2) * 16 + c3) * 16 + c4))
+ match char::from_u32(((c1 * 16 + c2) * 16 + c3) * 16 + c4)
{
Some(c) => output.push(c),
None => { output.push_str(&format!("\\u{:X}{:X}{:X}{:X}",c1,c2,c3,c4)); }
--
2.16.2

@ -1,11 +0,0 @@
--- idna-0.1.4/Cargo.toml 2017-07-13T18:21:49+02:00
+++ idna-0.1.4/Cargo.toml 2018-03-13T12:21:46.452973+01:00
@@ -18,7 +18,7 @@
name = "unit"
[dev-dependencies]
-rustc-test = "0.2"
+rustc-test = "0.3"
rustc-serialize = "0.3"
[dependencies]

@ -1,14 +1,16 @@
# Generated by rust2rpm
%bcond_without check
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}
%global crate idna
Name: rust-%{crate}
Version: 0.1.5
Release: 2%{?dist}
Release: 3%{?dist}
Summary: IDNA (Internationalizing Domain Names in Applications) and Punycode
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/idna
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
@ -16,28 +18,43 @@ Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(matches) >= 0.1.0 with crate(matches) < 0.2.0)
BuildRequires: (crate(unicode-bidi) >= 0.3.0 with crate(unicode-bidi) < 0.4.0)
BuildRequires: (crate(unicode-normalization) >= 0.1.5 with crate(unicode-normalization) < 0.2.0)
BuildRequires: (crate(matches/default) >= 0.1.0 with crate(matches/default) < 0.2.0)
BuildRequires: (crate(unicode-bidi/default) >= 0.3.0 with crate(unicode-bidi/default) < 0.4.0)
BuildRequires: (crate(unicode-normalization/default) >= 0.1.5 with crate(unicode-normalization/default) < 0.2.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(rustc-serialize) >= 0.3.0 with crate(rustc-serialize) < 0.4.0)
BuildRequires: (crate(rustc-test) >= 0.3.0 with crate(rustc-test) < 0.4.0)
BuildRequires: (crate(rustc-serialize/default) >= 0.3.0 with crate(rustc-serialize/default) < 0.4.0)
BuildRequires: (crate(rustc-test/default) >= 0.3.0 with crate(rustc-test/default) < 0.4.0)
%endif
%description
%{summary}.
%global _description \
IDNA (Internationalizing Domain Names in Applications) and Punycode.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
IDNA (Internationalizing Domain Names in Applications) and Punycode.
%description devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
@ -54,12 +71,10 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/src/{IdnaMappingTable.txt,make_uts46_mapping_table.py*}
%changelog
* Sat Nov 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.5-3
- Adapt to new packaging
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-idna
Loading…
Cancel
Save