parent
81ca38be2e
commit
c72d0a955c
@ -0,0 +1 @@
|
|||||||
|
/http-0.1.5.crate
|
@ -0,0 +1,11 @@
|
|||||||
|
--- http-0.1.5/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ http-0.1.5/Cargo.toml 2018-03-09T08:47:36.859960+01:00
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
[dependencies.fnv]
|
||||||
|
version = "1.0.5"
|
||||||
|
[dev-dependencies.ordermap]
|
||||||
|
-version = "0.3"
|
||||||
|
+version = "0.4"
|
||||||
|
|
||||||
|
[dev-dependencies.quickcheck]
|
||||||
|
version = "0.6"
|
@ -0,0 +1,70 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate http
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.1.5
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Set of types for representing HTTP requests and responses
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/http
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Bump ordermap to 0.4, https://github.com/hyperium/http/pull/185
|
||||||
|
Patch0: http-0.1.5-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(bytes) >= 0.4.0 with crate(bytes) < 0.5.0)
|
||||||
|
BuildRequires: (crate(fnv) >= 1.0.5 with crate(fnv) < 2.0.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(ordermap) >= 0.4.0 with crate(ordermap) < 0.5.0)
|
||||||
|
BuildRequires: (crate(quickcheck) >= 0.6.0 with crate(quickcheck) < 0.7.0)
|
||||||
|
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
|
||||||
|
BuildRequires: (crate(seahash) >= 3.0.5 with crate(seahash) < 4.0.0)
|
||||||
|
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
|
||||||
|
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A set of types for representing HTTP requests and responses.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc CHANGELOG.md README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.5-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue