parent
5415289054
commit
50db01044e
@ -0,0 +1 @@
|
|||||||
|
/html5ever-0.26.0.crate
|
@ -0,0 +1,9 @@
|
|||||||
|
--- html5ever-0.26.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ html5ever-0.26.0/Cargo.toml 2024-09-24T14:12:25.444112+00:00
|
||||||
|
@@ -43,5 +43,4 @@
|
||||||
|
[build-dependencies.syn]
|
||||||
|
version = "1"
|
||||||
|
features = ["extra-traits", "full", "fold"]
|
||||||
|
-[target."cfg(bench)".dev-dependencies.criterion]
|
||||||
|
-version = "0.3"
|
||||||
|
+
|
@ -0,0 +1,70 @@
|
|||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate html5ever
|
||||||
|
|
||||||
|
Name: rust-html5ever0.26
|
||||||
|
Version: 0.26.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: High-performance browser-grade HTML5 parser
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/html5ever
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip dependencies and normalize metadata
|
||||||
|
Patch: html5ever-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
High-performance browser-grade HTML5 parser.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue