import rust-html2text-0.6.0-4.el10

i10ce changed/i10ce/rust-html2text-0.6.0-4.el10
MSVSphere Packaging Team 4 weeks ago
commit 7fcff961e9
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/html2text-0.6.0.crate

@ -0,0 +1 @@
cf6e0a825f2afe1c07a77510e6dd8c58d50ea818 SOURCES/html2text-0.6.0.crate

@ -0,0 +1,32 @@
--- html2text-0.6.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ html2text-0.6.0/Cargo.toml 2024-10-04T12:37:51.783311+00:00
@@ -25,14 +25,6 @@
license = "MIT"
repository = "https://github.com/jugglerchris/rust-html2text/"
-[[example]]
-name = "html2term"
-path = "examples/html2term.rs"
-
-[[example]]
-name = "html2text"
-path = "examples/html2text.rs"
-
[dependencies.backtrace]
version = "0.3"
optional = true
@@ -52,14 +44,8 @@
[dependencies.xml5ever]
version = "0.17"
-[dev-dependencies.argparse]
-version = "0.2.2"
-
[features]
ansi_colours = []
default = []
html_trace = []
html_trace_bt = ["backtrace"]
-
-[target."cfg(unix)".dev-dependencies.termion]
-version = "1.5"

@ -0,0 +1,11 @@
[package]
cargo-toml-patch-comments = [
"drop example-only argparse and termion v1 dev-dependencies",
]
[scripts]
prep.post = [
"# drop unused example programs that pull in outdated dependencies",
"rm -rv examples/",
]

@ -0,0 +1,153 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate html2text
Name: rust-html2text
Version: 0.6.0
Release: %autorelease
Summary: Render HTML as plain text
License: MIT
URL: https://crates.io/crates/html2text
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop example-only argparse and termion v1 dev-dependencies
Patch: html2text-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Render HTML as plain text.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ansi_colours-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ansi_colours-devel %{_description}
This package contains library source intended for building other packages which
use the "ansi_colours" feature of the "%{crate}" crate.
%files -n %{name}+ansi_colours-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+backtrace-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+backtrace-devel %{_description}
This package contains library source intended for building other packages which
use the "backtrace" feature of the "%{crate}" crate.
%files -n %{name}+backtrace-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+html_trace-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+html_trace-devel %{_description}
This package contains library source intended for building other packages which
use the "html_trace" feature of the "%{crate}" crate.
%files -n %{name}+html_trace-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+html_trace_bt-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+html_trace_bt-devel %{_description}
This package contains library source intended for building other packages which
use the "html_trace_bt" feature of the "%{crate}" crate.
%files -n %{name}+html_trace_bt-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# drop unused example programs that pull in outdated dependencies
rm -rv examples/
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.6.0-4
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Oct 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.0-4
- Drop outdated, example-only dev-dependencies and example code
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Dec 11 2023 Fabio Valentini <decathorpe@gmail.com> - 0.6.0-1
- Update to version 0.6.0
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon May 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.5.1-1
- Initial import (#2209378)
## END: Generated by rpmautospec
Loading…
Cancel
Save