commit
8be87f09f3
@ -0,0 +1 @@
|
|||||||
|
SOURCES/html-escape-0.2.13.crate
|
@ -0,0 +1 @@
|
|||||||
|
3f217c889e94425936592bf659058fae21b196cf SOURCES/html-escape-0.2.13.crate
|
@ -0,0 +1,19 @@
|
|||||||
|
--- html-escape-0.2.13/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ html-escape-0.2.13/Cargo.toml 2024-09-29T16:17:06.602379+00:00
|
||||||
|
@@ -38,16 +38,8 @@
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/magiclen/html-escape"
|
||||||
|
|
||||||
|
-[[bench]]
|
||||||
|
-name = "encode"
|
||||||
|
-harness = false
|
||||||
|
-required-features = ["std"]
|
||||||
|
-
|
||||||
|
[dependencies.utf8-width]
|
||||||
|
version = "0.1"
|
||||||
|
-
|
||||||
|
-[dev-dependencies.bencher]
|
||||||
|
-version = "0.1.5"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
default = ["std"]
|
@ -0,0 +1,6 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Library for escaping special characters and unescaping HTML entities in HTML"
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused, benchmark-only bencher dev-dependency",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,130 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 6;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate html-escape
|
||||||
|
|
||||||
|
Name: rust-html-escape
|
||||||
|
Version: 0.2.13
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Library for escaping special characters and unescaping HTML entities in HTML
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/html-escape
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only bencher dev-dependency
|
||||||
|
Patch: html-escape-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
This library is for encoding/escaping special characters in HTML and
|
||||||
|
decoding/unescaping HTML entities as well.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.2.13-6
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sun Sep 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.2.13-6
|
||||||
|
- Drop unused, benchmark-only bencher dev-dependency
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.13-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.13-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.13-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.13-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Dec 23 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.13-1
|
||||||
|
- Update to version 0.2.13; Fixes RHBZ#2156064
|
||||||
|
|
||||||
|
* Mon Nov 07 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.12-1
|
||||||
|
- Update to version 0.2.12; Fixes RHBZ#2139350
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.11-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 17 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.11-1
|
||||||
|
- Update to version 0.2.11; Fixes RHBZ#2064994
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 06 2021 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.2.9-1
|
||||||
|
- Initial import (#2028890)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue