Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent df50ac61d3
commit a0b26aea6d
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/hostname-0.1.5.crate

@ -0,0 +1,8 @@
--- hostname-0.1.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ hostname-0.1.5/Cargo.toml 2019-01-28T21:58:41.641435+01:00
@@ -30,5 +30,3 @@
unstable = []
[target."cfg(any(unix, target_os = \"redox\"))".dependencies.libc]
version = "^0.2"
-[target."cfg(windows)".dependencies.winutil]
-version = "^0.1.1"

@ -0,0 +1,85 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}
%global crate hostname
Name: rust-%{crate}
Version: 0.1.5
Release: 1%{?dist}
Summary: Get hostname
License: MIT
URL: https://crates.io/crates/hostname
Source: %{crates_source}
# Initial patched metadata
# * No windows
Patch0: hostname-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
%global _description \
Get hostname. Compatible with windows and linux, redox.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 28 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.5-1
- Initial package

@ -0,0 +1 @@
SHA512 (hostname-0.1.5.crate) = 1b822bc6261cda2a52518c625790878eb4592fbccbea72b503da42322659b8e6c95ccac442753a6cf1d5d612413679221650e0c584bb06162c3b1c89d8bafb02

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-hostname
Loading…
Cancel
Save