parent
d39b542e6f
commit
6219e07dbb
@ -0,0 +1 @@
|
|||||||
|
/hkdf-0.7.0.crate
|
@ -0,0 +1,23 @@
|
|||||||
|
--- hkdf-0.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ hkdf-0.7.0/Cargo.toml 2019-03-13T23:34:42.285411+01:00
|
||||||
|
@@ -37,16 +37,16 @@
|
||||||
|
version = "0.1"
|
||||||
|
|
||||||
|
[dev-dependencies.crypto-tests]
|
||||||
|
-version = "0.5.*"
|
||||||
|
+version = "0.5"
|
||||||
|
|
||||||
|
[dev-dependencies.hex]
|
||||||
|
-version = "0.3.*"
|
||||||
|
+version = "0.3"
|
||||||
|
|
||||||
|
[dev-dependencies.sha-1]
|
||||||
|
-version = "0.8.*"
|
||||||
|
+version = "0.8"
|
||||||
|
|
||||||
|
[dev-dependencies.sha2]
|
||||||
|
-version = "0.8.*"
|
||||||
|
+version = "0.8"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
std = []
|
@ -0,0 +1,94 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
# * crypto-tests is not packaged
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate hkdf
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.7.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: HMAC-based Extract-and-Expand Key Derivation Function (HKDF)
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/hkdf
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Mangle '*' dependencies
|
||||||
|
Patch0: hkdf-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
BuildRequires: (crate(digest/default) >= 0.8.0 with crate(digest/default) < 0.9.0)
|
||||||
|
BuildRequires: (crate(hmac/default) >= 0.7.0 with crate(hmac/default) < 0.8.0)
|
||||||
|
%if %{with check}
|
||||||
|
BuildRequires: (crate(bencher/default) >= 0.1.0 with crate(bencher/default) < 0.2.0)
|
||||||
|
BuildRequires: (crate(crypto-tests/default) >= 0.5.0 with crate(crypto-tests/default) < 0.6.0)
|
||||||
|
BuildRequires: (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0)
|
||||||
|
BuildRequires: (crate(sha-1/default) >= 0.8.0 with crate(sha-1/default) < 0.9.0)
|
||||||
|
BuildRequires: (crate(sha2/default) >= 0.8.0 with crate(sha2/default) < 0.9.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global _description \
|
||||||
|
HMAC-based Extract-and-Expand Key Derivation Function (HKDF).
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "std" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (hkdf-0.7.0.crate) = 9a383fbcef5ac7115132b97a9fa6e3366f13dd4d376954ef3adb9b3d4348e408c13af0d900509d90e3b12334f2048a50e89858356684aea91886a316378e6384
|
@ -0,0 +1 @@
|
|||||||
|
1
|
@ -0,0 +1,5 @@
|
|||||||
|
---
|
||||||
|
standard-inventory-qcow2:
|
||||||
|
qemu:
|
||||||
|
# `cargo test` usually eats more than 1G.
|
||||||
|
m: 4G
|
@ -0,0 +1,13 @@
|
|||||||
|
---
|
||||||
|
- hosts: localhost
|
||||||
|
roles:
|
||||||
|
- role: standard-test-basic
|
||||||
|
tags:
|
||||||
|
- classic
|
||||||
|
repositories:
|
||||||
|
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||||
|
dest: rust
|
||||||
|
tests:
|
||||||
|
- rust/cargo-test
|
||||||
|
environment:
|
||||||
|
pkg: rust-hkdf
|
Loading…
Reference in new issue