commit
fb5c7eefb7
@ -0,0 +1 @@
|
|||||||
|
SOURCES/hickory-resolver-0.24.2.crate
|
@ -0,0 +1 @@
|
|||||||
|
c48f48e986b7a651a4bc9eedcc750c41fd51f344 SOURCES/hickory-resolver-0.24.2.crate
|
@ -0,0 +1,26 @@
|
|||||||
|
--- hickory-resolver-0.24.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ hickory-resolver-0.24.2/Cargo.toml 2024-12-16T14:41:54.959254+00:00
|
||||||
|
@@ -237,7 +237,6 @@
|
||||||
|
"hickory-proto/serde-config",
|
||||||
|
]
|
||||||
|
system-config = [
|
||||||
|
- "ipconfig",
|
||||||
|
"resolv-conf",
|
||||||
|
]
|
||||||
|
testing = []
|
||||||
|
@@ -250,10 +249,6 @@
|
||||||
|
"hickory-proto/webpki-roots",
|
||||||
|
]
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dependencies.ipconfig]
|
||||||
|
-version = "0.3.0"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
[badges.codecov]
|
||||||
|
branch = "main"
|
||||||
|
repository = "hickory-dns/hickory-dns"
|
||||||
|
@@ -266,3 +261,4 @@
|
||||||
|
level = "warn"
|
||||||
|
priority = 0
|
||||||
|
check-cfg = ["cfg(nightly)"]
|
||||||
|
+
|
@ -0,0 +1,17 @@
|
|||||||
|
--- hickory-resolver-0.24.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ hickory-resolver-0.24.2/Cargo.toml 2024-12-16T14:41:54.961254+00:00
|
||||||
|
@@ -170,14 +170,6 @@
|
||||||
|
"test-util",
|
||||||
|
]
|
||||||
|
|
||||||
|
-[dev-dependencies.tracing-subscriber]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = [
|
||||||
|
- "std",
|
||||||
|
- "fmt",
|
||||||
|
- "env-filter",
|
||||||
|
-]
|
||||||
|
-
|
||||||
|
[features]
|
||||||
|
backtrace = [
|
||||||
|
"dep:backtrace",
|
@ -0,0 +1,22 @@
|
|||||||
|
[tests]
|
||||||
|
run = ["none"]
|
||||||
|
comments = [
|
||||||
|
"/etc/hosts and /etc/resolv.conf are not available in mock",
|
||||||
|
"no internet connectivity in mock",
|
||||||
|
]
|
||||||
|
|
||||||
|
[features]
|
||||||
|
hide = [
|
||||||
|
# outdated dependencies
|
||||||
|
"rustls",
|
||||||
|
"tokio-rustls",
|
||||||
|
"dns-over-h3",
|
||||||
|
"dns-over-https",
|
||||||
|
"dns-over-https-rustls",
|
||||||
|
"dns-over-quic",
|
||||||
|
"dns-over-rustls",
|
||||||
|
"dnssec-ring",
|
||||||
|
"native-certs",
|
||||||
|
"webpki-roots",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,294 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 27
|
||||||
|
# * /etc/hosts and /etc/resolv.conf are not available in mock
|
||||||
|
# * no internet connectivity in mock
|
||||||
|
%bcond check 0
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate hickory-resolver
|
||||||
|
|
||||||
|
Name: rust-hickory-resolver
|
||||||
|
Version: 0.24.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Hickory DNS is a safe and secure DNS library
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/hickory-resolver
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip dependencies and normalize metadata
|
||||||
|
Patch: hickory-resolver-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * remove unused tracing-subscriber dev-dependency
|
||||||
|
Patch: hickory-resolver-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Hickory DNS is a safe and secure DNS library. This Resolver library
|
||||||
|
uses the Client library to perform all DNS queries. The Resolver is
|
||||||
|
intended to be a high-level library for any DNS record resolution see
|
||||||
|
Resolver and AsyncResolver for supported resolution types. The Client
|
||||||
|
can be used for other queries.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+backtrace-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+backtrace-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "backtrace" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+backtrace-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+dns-over-native-tls-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+dns-over-native-tls-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "dns-over-native-tls" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+dns-over-native-tls-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+dns-over-openssl-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+dns-over-openssl-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "dns-over-openssl" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+dns-over-openssl-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+dns-over-tls-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+dns-over-tls-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "dns-over-tls" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+dns-over-tls-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+dnssec-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+dnssec-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "dnssec" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+dnssec-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+dnssec-openssl-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+dnssec-openssl-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "dnssec-openssl" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+dnssec-openssl-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+resolv-conf-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+resolv-conf-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "resolv-conf" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+resolv-conf-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-config-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-config-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde-config" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-config-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+system-config-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+system-config-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "system-config" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+system-config-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+testing-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+testing-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "testing" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+testing-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tokio-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tokio-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tokio" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tokio-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tokio-native-tls-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tokio-native-tls-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tokio-native-tls" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tokio-native-tls-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tokio-openssl-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tokio-openssl-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tokio-openssl" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tokio-openssl-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tokio-runtime-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tokio-runtime-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tokio-runtime" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tokio-runtime-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.24.2-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Mon Dec 16 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.2-1
|
||||||
|
- Update to version 0.24.2; Fixes RHBZ#2331379
|
||||||
|
|
||||||
|
* Sun Sep 22 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.1-4
|
||||||
|
- Drop even more unused features and dependencies
|
||||||
|
|
||||||
|
* Sun Sep 22 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.1-3
|
||||||
|
- Drop unused support for dns-over-https and dns-over-quic
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 23 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.1-1
|
||||||
|
- Update to version 0.24.1; Fixes RHBZ#2275969
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 19 2023 Fabio Valentini <decathorpe@gmail.com> - 0.24.0-1
|
||||||
|
- Initial import (#2254533)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue