import rust-hickory-client-0.24.2-1.el10

i10ce changed/i10ce/rust-hickory-client-0.24.2-1.el10
MSVSphere Packaging Team 2 months ago
commit 598782c538
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/hickory-client-0.24.2.crate

@ -0,0 +1 @@
d4683fa10051f2ff3c17153ea2f993289130fce1 SOURCES/hickory-client-0.24.2.crate

@ -0,0 +1,34 @@
From 55af8d29c97545e7fa672d091010010cbd70cb5c Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Thu, 14 Dec 2023 12:51:52 +0100
Subject: [PATCH] do not run doctests which require internet access
---
src/lib.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/lib.rs b/src/lib.rs
index 7355114..76b64d2 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -98,7 +98,7 @@
//!
//! Using the Client to query for DNS records is easy enough, though it performs no resolution. The `hickory-resolver` has a simpler interface if that's what is desired. Over time that library will gain more features to generically query for different types.
//!
-//! ```rust
+//! ```rust,no_run
//! use std::net::Ipv4Addr;
//! use std::str::FromStr;
//! # use hickory_client::client::{Client, SyncClient};
@@ -223,7 +223,7 @@
//! This example is meant to show basic usage, using the #[tokio::main] macro to setup a simple runtime.
//! The Tokio documentation should be reviewed for more advanced usage.
//!
-//! ```rust
+//! ```rust,no_run
//! use std::net::Ipv4Addr;
//! use std::str::FromStr;
//! use tokio::net::TcpStream as TokioTcpStream;
--
2.43.0

@ -0,0 +1,17 @@
--- hickory-client-0.24.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hickory-client-0.24.2/Cargo.toml 2024-12-16T14:42:36.166460+00:00
@@ -137,14 +137,6 @@
"macros",
]
-[dev-dependencies.tracing-subscriber]
-version = "0.3"
-features = [
- "std",
- "fmt",
- "env-filter",
-]
-
[features]
backtrace = ["hickory-proto/backtrace"]
dns-over-https = ["hickory-proto/dns-over-https"]

@ -0,0 +1,28 @@
[package]
description = """\
Hickory DNS is a safe and secure DNS library. This is the Client library
with DNSSEC support. DNSSEC with NSEC validation for negative records,
is complete. The client supports dynamic DNS with SIG0 authenticated
requests, implementing easy to use high level funtions. Hickory DNS is
based on the Tokio and Futures libraries, which means it should be
easily integrated into other software that also use those libraries."""
[tests]
skip = ["client::async_client::tests::async_client"]
skip-exact = true
comments = ["skip a test that requires internet connectivity"]
[features]
hide = [
# outdated dependencies
"rustls",
"dns-over-https",
"dns-over-https-openssl",
"dns-over-https-rustls",
"dns-over-quic",
"dns-over-rustls",
"dnssec-ring",
"native-certs",
"webpki-roots",
]

@ -0,0 +1,222 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate hickory-client
Name: rust-hickory-client
Version: 0.24.2
Release: %autorelease
Summary: Hickory DNS is a safe and secure DNS library
License: MIT OR Apache-2.0
URL: https://crates.io/crates/hickory-client
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove unused tracing-subscriber dev-dependency
Patch: hickory-client-fix-metadata.diff
# * skip running doctests which require internet access
Patch: 0001-do-not-run-doctests-which-require-internet-access.patch
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Hickory DNS is a safe and secure DNS library. This is the Client library
with DNSSEC support. DNSSEC with NSEC validation for negative records,
is complete. The client supports dynamic DNS with SIG0 authenticated
requests, implementing easy to use high level funtions. Hickory DNS is
based on the Tokio and Futures libraries, which means it should be
easily integrated into other software that also use those libraries.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+backtrace-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+backtrace-devel %{_description}
This package contains library source intended for building other packages which
use the "backtrace" feature of the "%{crate}" crate.
%files -n %{name}+backtrace-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-native-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-native-tls-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-native-tls" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-native-tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-openssl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-openssl-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-openssl" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-openssl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dns-over-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dns-over-tls-devel %{_description}
This package contains library source intended for building other packages which
use the "dns-over-tls" feature of the "%{crate}" crate.
%files -n %{name}+dns-over-tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dnssec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dnssec-devel %{_description}
This package contains library source intended for building other packages which
use the "dnssec" feature of the "%{crate}" crate.
%files -n %{name}+dnssec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dnssec-openssl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dnssec-openssl-devel %{_description}
This package contains library source intended for building other packages which
use the "dnssec-openssl" feature of the "%{crate}" crate.
%files -n %{name}+dnssec-openssl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mdns-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mdns-devel %{_description}
This package contains library source intended for building other packages which
use the "mdns" feature of the "%{crate}" crate.
%files -n %{name}+mdns-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-config-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-config-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-config" feature of the "%{crate}" crate.
%files -n %{name}+serde-config-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip a test that requires internet connectivity
%cargo_test -- -- --exact --skip client::async_client::tests::async_client
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.24.2-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Mon Dec 16 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.2-1
- Update to version 0.24.2; Fixes RHBZ#2331377
* Sun Sep 22 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.1-4
- Drop even more unused features and dependencies
* Sun Sep 22 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.1-3
- Drop unused support for dns-over-https and dns-over-quic
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Tue Apr 23 2024 Fabio Valentini <decathorpe@gmail.com> - 0.24.1-1
- Update to version 0.24.1; Fixes RHBZ#2275967
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Tue Dec 19 2023 Fabio Valentini <decathorpe@gmail.com> - 0.24.0-1
- Initial import (#2254534)
## END: Generated by rpmautospec
Loading…
Cancel
Save