commit
76a2aeaea5
@ -0,0 +1 @@
|
|||||||
|
SOURCES/heapless-0.7.17.crate
|
@ -0,0 +1 @@
|
|||||||
|
bfad1d7b217af599c6dbe629410882455fafe72b SOURCES/heapless-0.7.17.crate
|
@ -0,0 +1,3 @@
|
|||||||
|
# rust-heapless0.7
|
||||||
|
|
||||||
|
The rust-heapless0.7 package
|
@ -0,0 +1,33 @@
|
|||||||
|
--- heapless-0.7.17/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ heapless-0.7.17/Cargo.toml 2024-03-25T22:10:29.067024+00:00
|
||||||
|
@@ -63,29 +63,13 @@
|
||||||
|
|
||||||
|
[features]
|
||||||
|
__trybuild = []
|
||||||
|
-cas = ["atomic-polyfill"]
|
||||||
|
+cas = []
|
||||||
|
default = ["cas"]
|
||||||
|
defmt-impl = ["defmt"]
|
||||||
|
mpmc_large = []
|
||||||
|
ufmt-impl = ["ufmt-write"]
|
||||||
|
x86-sync-pool = []
|
||||||
|
|
||||||
|
-[target."cfg(target_arch = \"avr\")".dependencies.atomic-polyfill]
|
||||||
|
-version = "1"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
[target."cfg(target_arch = \"x86_64\")".dependencies.spin]
|
||||||
|
version = "0.9.2"
|
||||||
|
|
||||||
|
-[target.riscv32i-unknown-none-elf.dependencies.atomic-polyfill]
|
||||||
|
-version = "1"
|
||||||
|
-
|
||||||
|
-[target.riscv32imc-unknown-none-elf.dependencies.atomic-polyfill]
|
||||||
|
-version = "1"
|
||||||
|
-
|
||||||
|
-[target.thumbv6m-none-eabi.dependencies.atomic-polyfill]
|
||||||
|
-version = "1"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[target.xtensa-esp32s2-none-elf.dependencies.atomic-polyfill]
|
||||||
|
-version = "1"
|
@ -0,0 +1,12 @@
|
|||||||
|
--- heapless-0.7.17/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ heapless-0.7.17/Cargo.toml 2024-03-25T22:10:35.867072+00:00
|
||||||
|
@@ -55,9 +55,6 @@
|
||||||
|
version = "0.1"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
-[dev-dependencies.ufmt]
|
||||||
|
-version = "0.1"
|
||||||
|
-
|
||||||
|
[build-dependencies.rustc_version]
|
||||||
|
version = "0.4.0"
|
||||||
|
|
@ -0,0 +1,6 @@
|
|||||||
|
[features]
|
||||||
|
hide = [
|
||||||
|
"__trybuild",
|
||||||
|
"defmt",
|
||||||
|
"defmt-impl",
|
||||||
|
]
|
@ -0,0 +1,168 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate heapless
|
||||||
|
|
||||||
|
Name: rust-heapless0.7
|
||||||
|
Version: 0.7.17
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Static friendly data structures that don't require dynamic memory allocation
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/heapless
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip dependencies and normalize metadata
|
||||||
|
Patch: heapless-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# can't package ufmt, test errors
|
||||||
|
Patch: heapless-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
`static` friendly data structures that don't require dynamic memory
|
||||||
|
allocation.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/suppressions.txt
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+cas-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+cas-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "cas" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+cas-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+mpmc_large-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+mpmc_large-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "mpmc_large" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+mpmc_large-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+ufmt-impl-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+ufmt-impl-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "ufmt-impl" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+ufmt-impl-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+ufmt-write-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+ufmt-write-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "ufmt-write" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+ufmt-write-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+x86-sync-pool-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+x86-sync-pool-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "x86-sync-pool" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+x86-sync-pool-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.7.17-2
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.17-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Mar 25 2024 Michel Lind <salimma@fedoraproject.org> - 0.7.17-1
|
||||||
|
- Initial package (rhbz#2271528)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue