Update to 0.8.0 (rhbz#2248736)

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel10
Michel Lind 11 months ago
parent 711769c840
commit 1720a002dd
No known key found for this signature in database
GPG Key ID: 8B229D2F7CCC04F2

1
.gitignore vendored

@ -1 +1,2 @@
/heapless-0.7.16.crate /heapless-0.7.16.crate
/heapless-0.8.0.crate

@ -1,12 +1,12 @@
--- heapless-0.7.16/Cargo.toml 1970-01-01T00:00:01+00:00 --- heapless-0.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ heapless-0.7.16/Cargo.toml 2023-02-23T19:44:55.325917+00:00 +++ heapless-0.8.0/Cargo.toml 2024-03-21T17:51:19.839547+00:00
@@ -55,9 +55,6 @@ @@ -70,9 +70,6 @@
version = "0.1" version = "0.1"
optional = true optional = true
-[dev-dependencies.ufmt] -[dev-dependencies.ufmt]
-version = "0.1" -version = "0.2"
- -
[build-dependencies.rustc_version] [features]
version = "0.4.0" defmt-03 = ["dep:defmt"]
mpmc_large = []

@ -1,26 +1,22 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 26
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate heapless %global crate heapless
Name: rust-heapless Name: rust-heapless
Version: 0.7.16 Version: 0.8.0
Release: %autorelease Release: %autorelease
Summary: Static friendly data structures that don't require dynamic memory allocation Summary: Static friendly data structures that don't require dynamic memory allocation
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/heapless URL: https://crates.io/crates/heapless
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: heapless-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# can't package ufmt, test errors # can't package ufmt, test errors
Patch: heapless-fix-metadata.diff Patch: heapless-fix-metadata.diff
# const_err lint is removed: https://github.com/rust-lang/rust/issues/71800
Patch: heapless-rm-const_err.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
`static` friendly data structures that don't require dynamic memory `static` friendly data structures that don't require dynamic memory
@ -41,6 +37,7 @@ use the "%{crate}" crate.
%license %{crate_instdir}/LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT %license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md %doc %{crate_instdir}/README.md
%doc %{crate_instdir}/suppressions.txt %doc %{crate_instdir}/suppressions.txt
%{crate_instdir}/ %{crate_instdir}/
@ -57,30 +54,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+atomic-polyfill-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+atomic-polyfill-devel %{_description}
This package contains library source intended for building other packages which
use the "atomic-polyfill" feature of the "%{crate}" crate.
%files -n %{name}+atomic-polyfill-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cas-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cas-devel %{_description}
This package contains library source intended for building other packages which
use the "cas" feature of the "%{crate}" crate.
%files -n %{name}+cas-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mpmc_large-devel %package -n %{name}+mpmc_large-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -93,56 +66,56 @@ use the "mpmc_large" feature of the "%{crate}" crate.
%files -n %{name}+mpmc_large-devel %files -n %{name}+mpmc_large-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+portable-atomic-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+portable-atomic-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate. use the "portable-atomic" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+portable-atomic-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ufmt-impl-devel %package -n %{name}+portable-atomic-critical-section-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+ufmt-impl-devel %{_description} %description -n %{name}+portable-atomic-critical-section-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use the "ufmt-impl" feature of the "%{crate}" crate. use the "portable-atomic-critical-section" feature of the "%{crate}" crate.
%files -n %{name}+ufmt-impl-devel %files -n %{name}+portable-atomic-critical-section-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ufmt-write-devel %package -n %{name}+portable-atomic-unsafe-assume-single-core-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+ufmt-write-devel %{_description} %description -n %{name}+portable-atomic-unsafe-assume-single-core-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use the "ufmt-write" feature of the "%{crate}" crate. use the "portable-atomic-unsafe-assume-single-core" feature of the "%{crate}" crate.
%files -n %{name}+ufmt-write-devel %files -n %{name}+portable-atomic-unsafe-assume-single-core-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+x86-sync-pool-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+x86-sync-pool-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use the "x86-sync-pool" feature of the "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+x86-sync-pool-devel %files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1,5 +0,0 @@
[DEFAULT]
unwanted-features =
__trybuild
defmt
defmt-impl

@ -0,0 +1,5 @@
[features]
hide = [
"defmt-03",
"ufmt",
]

@ -1 +1 @@
SHA512 (heapless-0.7.16.crate) = c67633044298013fc584fba5dde8a85f84f259d138d6f0912de4368ceee0b7194c5cde705b4a04186a4420757336814335b6b935b5e5380eb341720090b56428 SHA512 (heapless-0.8.0.crate) = 9cbcc4b5b763b9478d0070823aa0412805e4b08f28cdb92b3ad6c6add997d0abac13f25cd6a1dc05136d2100304e8617af55f165a4acad3499c15407d7b3aab3

Loading…
Cancel
Save