import rust-hdrhistogram-7.5.4-4.el10

i10ce changed/i10ce/rust-hdrhistogram-7.5.4-4.el10
MSVSphere Packaging Team 2 months ago
commit 01b80de3d0
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/hdrhistogram-7.5.4.crate

@ -0,0 +1 @@
4d53f966716bfa971635b8075d510b116b36c8c3 SOURCES/hdrhistogram-7.5.4.crate

@ -0,0 +1,11 @@
--- hdrhistogram-7.5.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hdrhistogram-7.5.4/Cargo.toml 2024-09-21T21:16:07.891291+00:00
@@ -47,7 +47,7 @@
required-features = ["serialization"]
[dependencies.base64]
-version = "0.21"
+version = "0.22"
optional = true
[dependencies.byteorder]

@ -0,0 +1,9 @@
[package]
cargo-toml-patch-comments = [
"bump base64 dependency from 0.21 to 0.22",
]
[tests]
run = ["none"]
comments = ["missing dev-dependencies: ieee754 ^0.2.2, rug ^1.2.0"]

@ -0,0 +1,193 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
# * missing dev-dependencies: ieee754 ^0.2.2, rug ^1.2.0
%bcond_with check
%global debug_package %{nil}
%global crate hdrhistogram
Name: rust-hdrhistogram
Version: 7.5.4
Release: %autorelease
Summary: Port of HdrHistogram to Rust
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/hdrhistogram
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump base64 dependency from 0.21 to 0.22
Patch: hdrhistogram-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A port of HdrHistogram to Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+base64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+base64-devel %{_description}
This package contains library source intended for building other packages which
use the "base64" feature of the "%{crate}" crate.
%files -n %{name}+base64-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bench_private-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bench_private-devel %{_description}
This package contains library source intended for building other packages which
use the "bench_private" feature of the "%{crate}" crate.
%files -n %{name}+bench_private-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crossbeam-channel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crossbeam-channel-devel %{_description}
This package contains library source intended for building other packages which
use the "crossbeam-channel" feature of the "%{crate}" crate.
%files -n %{name}+crossbeam-channel-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+flate2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flate2-devel %{_description}
This package contains library source intended for building other packages which
use the "flate2" feature of the "%{crate}" crate.
%files -n %{name}+flate2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nom-devel %{_description}
This package contains library source intended for building other packages which
use the "nom" feature of the "%{crate}" crate.
%files -n %{name}+nom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialization-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serialization-devel %{_description}
This package contains library source intended for building other packages which
use the "serialization" feature of the "%{crate}" crate.
%files -n %{name}+serialization-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sync-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sync-devel %{_description}
This package contains library source intended for building other packages which
use the "sync" feature of the "%{crate}" crate.
%files -n %{name}+sync-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 7.5.4-4
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sat Sep 21 2024 Fabio Valentini <decathorpe@gmail.com> - 7.5.4-4
- Bump base64 dependency from 0.21 to 0.22
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 7.5.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 7.5.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Nov 25 2023 Fabio Valentini <decathorpe@gmail.com> - 7.5.4-1
- Update to version 7.5.4; Fixes RHBZ#2250429
* Mon Nov 13 2023 Fabio Valentini <decathorpe@gmail.com> - 7.5.3-1
- Update to version 7.5.3; Fixes RHBZ#2249204
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 7.5.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Thu Jul 06 2023 Fabio Valentini <decathorpe@gmail.com> - 7.5.2-1
- Initial import (#2214390)
## END: Generated by rpmautospec
Loading…
Cancel
Save