Merge branch 'rawhide' into epel9

epel9
Fabio Valentini 2 years ago
commit d6b286eb4b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -13,3 +13,5 @@
/hashbrown-0.8.2.crate /hashbrown-0.8.2.crate
/hashbrown-0.9.1.crate /hashbrown-0.9.1.crate
/hashbrown-0.11.2.crate /hashbrown-0.11.2.crate
/hashbrown-0.12.2.crate
/hashbrown-0.12.3.crate

@ -0,0 +1,8 @@
[DEFAULT]
unwanted-features =
alloc
compiler_builtins
core
nightly
rustc-dep-of-std
rustc-internal-api

@ -1,34 +0,0 @@
--- hashbrown-0.11.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ hashbrown-0.11.2/Cargo.toml 2021-09-30T11:07:56.435200+00:00
@@ -29,23 +29,9 @@
optional = true
default-features = false
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
[dependencies.bumpalo]
version = "3.5.0"
optional = true
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.rayon]
version = "1.0"
@@ -78,7 +64,4 @@
ahash-compile-time-rng = ["ahash/compile-time-rng"]
default = ["ahash", "inline-more"]
inline-more = []
-nightly = []
raw = []
-rustc-dep-of-std = ["nightly", "core", "compiler_builtins", "alloc", "rustc-internal-api"]
-rustc-internal-api = []

@ -1,29 +1,22 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 21
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate hashbrown %global crate hashbrown
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.11.2 Version: 0.12.3
Release: %autorelease Release: %autorelease
Summary: Rust port of Google's SwissTable hash map Summary: Rust port of Google's SwissTable hash map
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: MIT OR Apache-2.0
License: ASL 2.0 or MIT License: MIT or ASL 2.0
URL: https://crates.io/crates/hashbrown URL: https://crates.io/crates/hashbrown
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * drop dependencies on compiler internals
# * drop nightly-only features
Patch0: hashbrown-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Rust port of Google's SwissTable hash map.} Rust port of Google's SwissTable hash map.}
@ -36,13 +29,15 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md CHANGELOG.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ahash-devel %package -n %{name}+ahash-devel
Summary: %{summary} Summary: %{summary}
@ -62,11 +57,11 @@ BuildArch: noarch
%description -n %{name}+ahash-devel %{_description} %description -n %{name}+ahash-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "ahash" feature of "%{crate}" crate. use the "ahash" feature of the "%{crate}" crate.
%files -n %{name}+ahash-devel %files -n %{name}+ahash-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ahash-compile-time-rng-devel %package -n %{name}+ahash-compile-time-rng-devel
Summary: %{summary} Summary: %{summary}
@ -74,11 +69,11 @@ BuildArch: noarch
%description -n %{name}+ahash-compile-time-rng-devel %{_description} %description -n %{name}+ahash-compile-time-rng-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "ahash-compile-time-rng" feature of "%{crate}" crate. use the "ahash-compile-time-rng" feature of the "%{crate}" crate.
%files -n %{name}+ahash-compile-time-rng-devel %files -n %{name}+ahash-compile-time-rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bumpalo-devel %package -n %{name}+bumpalo-devel
Summary: %{summary} Summary: %{summary}
@ -86,11 +81,11 @@ BuildArch: noarch
%description -n %{name}+bumpalo-devel %{_description} %description -n %{name}+bumpalo-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "bumpalo" feature of "%{crate}" crate. use the "bumpalo" feature of the "%{crate}" crate.
%files -n %{name}+bumpalo-devel %files -n %{name}+bumpalo-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+inline-more-devel %package -n %{name}+inline-more-devel
Summary: %{summary} Summary: %{summary}
@ -98,11 +93,11 @@ BuildArch: noarch
%description -n %{name}+inline-more-devel %{_description} %description -n %{name}+inline-more-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "inline-more" feature of "%{crate}" crate. use the "inline-more" feature of the "%{crate}" crate.
%files -n %{name}+inline-more-devel %files -n %{name}+inline-more-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+raw-devel %package -n %{name}+raw-devel
Summary: %{summary} Summary: %{summary}
@ -110,11 +105,11 @@ BuildArch: noarch
%description -n %{name}+raw-devel %{_description} %description -n %{name}+raw-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "raw" feature of "%{crate}" crate. use the "raw" feature of the "%{crate}" crate.
%files -n %{name}+raw-devel %files -n %{name}+raw-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rayon-devel %package -n %{name}+rayon-devel
Summary: %{summary} Summary: %{summary}
@ -122,11 +117,11 @@ BuildArch: noarch
%description -n %{name}+rayon-devel %{_description} %description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "rayon" feature of "%{crate}" crate. use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel %files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -134,11 +129,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -155,8 +150,14 @@ which use "serde" feature of "%{crate}" crate.
%if %{with check} %if %{with check}
%check %check
%ifarch %{arm}
# * some doctests inconsistently fail on armv7hl:
# https://github.com/rust-lang/hashbrown/issues/349
%cargo_test -- --lib
%else
%cargo_test %cargo_test
%endif %endif
%endif
%changelog %changelog
%autochangelog %autochangelog

@ -1 +1 @@
SHA512 (hashbrown-0.11.2.crate) = c21ca68fd49bbb741901f59fed04cc124b8da99e2a4dfc26e2e5e1140637872b344612a01691bd30cc771575c571be15f756c84dde225441699cd2322af2ad6c SHA512 (hashbrown-0.12.3.crate) = b3700fcd659a21a6b9b3777c18b37a83bf25542b4e8f2b963779a122f5d22e1742c064cfc03e649583e7dd5c6e90ca8407f8c51a0e8755f6a108682853022f76

Loading…
Cancel
Save