drop dependencies on compiler internals

epel9
Fabio Valentini 4 years ago
parent f061ef1be5
commit aa2fbcdbb2
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,6 +1,35 @@
--- hashbrown-0.9.1/Cargo.toml 2020-09-28T19:15:21+00:00
+++ hashbrown-0.9.1/Cargo.toml 2020-09-28T22:17:44.277161+00:00
@@ -65,7 +65,7 @@
+++ hashbrown-0.9.1/Cargo.toml 2020-11-09T14:18:14.491392+00:00
@@ -29,20 +29,6 @@
optional = true
default-features = false
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
-
[dependencies.rayon]
version = "1.0"
optional = true
@@ -51,6 +37,7 @@
version = "1.0.25"
optional = true
default-features = false
+
[dev-dependencies.doc-comment]
version = "0.3.1"
@@ -65,7 +52,7 @@
version = "1.0"
[dev-dependencies.rustc-hash]
@ -9,3 +38,11 @@
[dev-dependencies.serde_test]
version = "1.0"
@@ -74,7 +61,4 @@
ahash-compile-time-rng = ["ahash/compile-time-rng"]
default = ["ahash", "inline-more"]
inline-more = []
-nightly = []
raw = []
-rustc-dep-of-std = ["nightly", "core", "compiler_builtins", "alloc", "rustc-internal-api"]
-rustc-internal-api = []

@ -1,4 +1,4 @@
# Generated by rust2rpm 13
# Generated by rust2rpm 15
%bcond_without check
%global debug_package %{nil}
@ -6,7 +6,7 @@
Name: rust-%{crate}
Version: 0.9.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Rust port of Google's SwissTable hash map
# Upstream license specification: Apache-2.0/MIT
@ -15,6 +15,7 @@ URL: https://crates.io/crates/hashbrown
Source: %{crates_source}
# Initial patched metadata
# * No locked dependencies
# * Drop dependencies on compiler internals
Patch0: hashbrown-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -79,42 +80,6 @@ which use "ahash-compile-time-rng" feature of "%{crate}" crate.
%files -n %{name}+ahash-compile-time-rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+compiler_builtins-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compiler_builtins-devel %{_description}
This package contains library source intended for building other packages
which use "compiler_builtins" feature of "%{crate}" crate.
%files -n %{name}+compiler_builtins-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+core-devel %{_description}
This package contains library source intended for building other packages
which use "core" feature of "%{crate}" crate.
%files -n %{name}+core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+inline-more-devel
Summary: %{summary}
BuildArch: noarch
@ -127,18 +92,6 @@ which use "inline-more" feature of "%{crate}" crate.
%files -n %{name}+inline-more-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+raw-devel
Summary: %{summary}
BuildArch: noarch
@ -163,30 +116,6 @@ which use "rayon" feature of "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustc-dep-of-std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc-dep-of-std-devel %{_description}
This package contains library source intended for building other packages
which use "rustc-dep-of-std" feature of "%{crate}" crate.
%files -n %{name}+rustc-dep-of-std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustc-internal-api-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc-internal-api-devel %{_description}
This package contains library source intended for building other packages
which use "rustc-internal-api" feature of "%{crate}" crate.
%files -n %{name}+rustc-internal-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -218,6 +147,9 @@ which use "serde" feature of "%{crate}" crate.
%endif
%changelog
* Mon Nov 09 2020 Fabio Valentini <decathorpe@gmail.com> - 0.9.1-2
- Drop dependencies on compiler internals.
* Mon Sep 28 2020 Fabio Valentini <decathorpe@gmail.com> - 0.9.1-1
- Update to version 0.9.1.

Loading…
Cancel
Save