Update to version 0.14.0; Fixes RHBZ#2212580

epel9
Fabio Valentini 2 years ago
parent 9044d31f3e
commit 9de4d945e5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -16,3 +16,4 @@
/hashbrown-0.12.2.crate
/hashbrown-0.12.3.crate
/hashbrown-0.13.2.crate
/hashbrown-0.14.0.crate

@ -1,3 +0,0 @@
# rust-hashbrown
The rust-hashbrown package

@ -0,0 +1,45 @@
--- hashbrown-0.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hashbrown-0.14.0/Cargo.toml 2023-07-05T17:51:26.874507+00:00
@@ -47,25 +47,11 @@
optional = true
default-features = false
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
[dependencies.allocator-api2]
version = "0.2.9"
features = ["alloc"]
optional = true
default-features = false
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.rayon]
version = "1.0"
@@ -116,16 +102,4 @@
"allocator-api2",
]
inline-more = []
-nightly = [
- "allocator-api2?/nightly",
- "bumpalo/allocator_api",
-]
raw = []
-rustc-dep-of-std = [
- "nightly",
- "core",
- "compiler_builtins",
- "alloc",
- "rustc-internal-api",
-]
-rustc-internal-api = []

@ -1,22 +1,25 @@
# Generated by rust2rpm 23
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate hashbrown
Name: rust-hashbrown
Version: 0.13.2
Version: 0.14.0
Release: %autorelease
Summary: Rust port of Google's SwissTable hash map
License: MIT OR Apache-2.0
URL: https://crates.io/crates/hashbrown
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop dependencies on compiler internals
Patch: hashbrown-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Rust port of Google's SwissTable hash map.}
A Rust port of Google's SwissTable hash map.}
%description %{_description}
@ -60,16 +63,16 @@ use the "ahash" feature of the "%{crate}" crate.
%files -n %{name}+ahash-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bumpalo-devel
%package -n %{name}+allocator-api2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bumpalo-devel %{_description}
%description -n %{name}+allocator-api2-devel %{_description}
This package contains library source intended for building other packages which
use the "bumpalo" feature of the "%{crate}" crate.
use the "allocator-api2" feature of the "%{crate}" crate.
%files -n %{name}+bumpalo-devel
%files -n %{name}+allocator-api2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+inline-more-devel
@ -108,6 +111,18 @@ use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch

@ -1,8 +0,0 @@
[DEFAULT]
unwanted-features =
alloc
compiler_builtins
core
nightly
rustc-dep-of-std
rustc-internal-api

@ -1 +1 @@
SHA512 (hashbrown-0.13.2.crate) = 21dae7a283326d21e16bb32ae0dd1481c4936939a32a06478a3351c2dec97941be532437b808e99ac40e7900a75433fe0efbd852158659a682461245e19d0e70
SHA512 (hashbrown-0.14.0.crate) = f0fbdf81517f59a0b67f792a4097f1131d346b2b4cbda93590749cef7f9f1c9029e0e182f58c23b74d3028f7502c30b9593c1eb4da37f95388d74b14582b8959

Loading…
Cancel
Save