Update to version 0.12.2; Fixes RHBZ#2041300

epel9
Fabio Valentini 3 years ago
parent 4a1699c957
commit 7438391ded
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -13,3 +13,4 @@
/hashbrown-0.8.2.crate
/hashbrown-0.9.1.crate
/hashbrown-0.11.2.crate
/hashbrown-0.12.2.crate

@ -0,0 +1,8 @@
[DEFAULT]
unwanted-features =
alloc
compiler_builtins
core
nightly
rustc-dep-of-std
rustc-internal-api

@ -1,34 +0,0 @@
--- hashbrown-0.11.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ hashbrown-0.11.2/Cargo.toml 2021-09-30T11:07:56.435200+00:00
@@ -29,23 +29,9 @@
optional = true
default-features = false
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
[dependencies.bumpalo]
version = "3.5.0"
optional = true
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.rayon]
version = "1.0"
@@ -78,7 +64,4 @@
ahash-compile-time-rng = ["ahash/compile-time-rng"]
default = ["ahash", "inline-more"]
inline-more = []
-nightly = []
raw = []
-rustc-dep-of-std = ["nightly", "core", "compiler_builtins", "alloc", "rustc-internal-api"]
-rustc-internal-api = []

@ -1,29 +1,22 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate hashbrown
Name: rust-%{crate}
Version: 0.11.2
Version: 0.12.2
Release: %autorelease
Summary: Rust port of Google's SwissTable hash map
# Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/hashbrown
Source: %{crates_source}
# Initial patched metadata
# * drop dependencies on compiler internals
# * drop nightly-only features
Patch0: hashbrown-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Rust port of Google's SwissTable hash map.}
@ -36,13 +29,15 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ahash-devel
Summary: %{summary}
@ -62,11 +57,11 @@ BuildArch: noarch
%description -n %{name}+ahash-devel %{_description}
This package contains library source intended for building other packages
which use "ahash" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "ahash" feature of the "%{crate}" crate.
%files -n %{name}+ahash-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ahash-compile-time-rng-devel
Summary: %{summary}
@ -74,11 +69,11 @@ BuildArch: noarch
%description -n %{name}+ahash-compile-time-rng-devel %{_description}
This package contains library source intended for building other packages
which use "ahash-compile-time-rng" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "ahash-compile-time-rng" feature of the "%{crate}" crate.
%files -n %{name}+ahash-compile-time-rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bumpalo-devel
Summary: %{summary}
@ -86,11 +81,11 @@ BuildArch: noarch
%description -n %{name}+bumpalo-devel %{_description}
This package contains library source intended for building other packages
which use "bumpalo" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "bumpalo" feature of the "%{crate}" crate.
%files -n %{name}+bumpalo-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+inline-more-devel
Summary: %{summary}
@ -98,11 +93,11 @@ BuildArch: noarch
%description -n %{name}+inline-more-devel %{_description}
This package contains library source intended for building other packages
which use "inline-more" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "inline-more" feature of the "%{crate}" crate.
%files -n %{name}+inline-more-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+raw-devel
Summary: %{summary}
@ -110,11 +105,11 @@ BuildArch: noarch
%description -n %{name}+raw-devel %{_description}
This package contains library source intended for building other packages
which use "raw" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "raw" feature of the "%{crate}" crate.
%files -n %{name}+raw-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rayon-devel
Summary: %{summary}
@ -122,11 +117,11 @@ BuildArch: noarch
%description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages
which use "rayon" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -134,11 +129,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (hashbrown-0.11.2.crate) = c21ca68fd49bbb741901f59fed04cc124b8da99e2a4dfc26e2e5e1140637872b344612a01691bd30cc771575c571be15f756c84dde225441699cd2322af2ad6c
SHA512 (hashbrown-0.12.2.crate) = 5adbb650a40c2f9267a9c729cf377001b07eb91824470d7da459860534683b6f40fa8f14bb997a8f3df64eda561d1ba658e95b6c35502de7a76225bea8c56d46

Loading…
Cancel
Save