Update to 0.2.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 054d11d35d
commit 49b74df13c
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/hashbrown-0.1.8.crate /hashbrown-0.1.8.crate
/hashbrown-0.2.0.crate

@ -1,11 +1,11 @@
--- hashbrown-0.1.8/Cargo.toml 1969-12-31T16:00:00-08:00 --- hashbrown-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ hashbrown-0.1.8/Cargo.toml 2019-01-17T12:38:35.191437-08:00 +++ hashbrown-0.2.0/Cargo.toml 2019-04-04T06:09:30.156953+00:00
@@ -20,6 +20,8 @@ @@ -15,7 +15,7 @@
categories = ["data-structures", "no-std"] name = "hashbrown"
license = "Apache-2.0/MIT" version = "0.2.0"
repository = "https://github.com/Amanieu/hashbrown" authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+exclude = [".travis.yml", "bors.toml"] -exclude = [".travis.yml", "bors.toml"]
+ +exclude = [".travis.yml", "bors.toml", "/ci/*"]
[dependencies.byteorder] description = "A Rust port of Google's SwissTable hash map"
version = "1.0" readme = "README.md"
default-features = false keywords = ["hash", "no_std", "hashmap", "swisstable"]

@ -1,30 +1,25 @@
# Generated by rust2rpm # Generated by rust2rpm
# rustc-hash is not packaged
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate hashbrown %global crate hashbrown
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.8 Version: 0.2.0
Release: 2%{?dist} Release: 1%{?dist}
Summary: Rust port of Google's SwissTable hash map Summary: Rust port of Google's SwissTable hash map
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT License: ASL 2.0 or MIT
URL: https://crates.io/crates/hashbrown URL: https://crates.io/crates/hashbrown
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * exclude CI files <https://github.com/Amanieu/hashbrown/pull/41> # * Exclude CI files, https://github.com/Amanieu/hashbrown/pull/57
Patch0: hashbrown-fix-metadata.diff Patch0: hashbrown-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
BuildRequires: (crate(rayon/default) >= 1.0.0 with crate(rayon/default) < 2.0.0)
BuildRequires: (crate(scopeguard) >= 0.3.0 with crate(scopeguard) < 0.4.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
%if %{with check} %if %{with check}
BuildRequires: (crate(lazy_static/default) >= 1.2.0 with crate(lazy_static/default) < 1.3.0) BuildRequires: (crate(lazy_static/default) >= 1.2.0 with crate(lazy_static/default) < 1.3.0)
BuildRequires: (crate(rand/default) >= 0.5.1 with crate(rand/default) < 0.6.0) BuildRequires: (crate(rand/default) >= 0.5.1 with crate(rand/default) < 0.6.0)
@ -89,7 +84,7 @@ which use "serde" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%build %build
@ -104,6 +99,9 @@ which use "serde" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Thu Apr 04 08:09:30 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-1
- Update to 0.2.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.8-2 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (hashbrown-0.1.8.crate) = 297fc503bd716faaf6dbb76211522e792688828f7032c9045a298f85e8777fafa233d51632b7e204d07292b3478e8b69f1cb697192033dfc91b079de7f230032 SHA512 (hashbrown-0.2.0.crate) = a6e9df3af4751bc7d466c19ec430aed640483bfc76e1fa8071a764fd4e37dd8eaaf8b86c73347b7634ea928dd1dbd8a0c4c41cbb993e90fbaad830b29970293f

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-hashbrown
Loading…
Cancel
Save