commit
6c6d89b833
@ -0,0 +1 @@
|
|||||||
|
SOURCES/half-1.8.3.crate
|
@ -0,0 +1 @@
|
|||||||
|
2524a713267dbda65ea89313a93be2c83efe6a89 SOURCES/half-1.8.3.crate
|
@ -0,0 +1,25 @@
|
|||||||
|
--- half-1.8.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ half-1.8.3/Cargo.toml 2024-10-23T14:43:49.268166+00:00
|
||||||
|
@@ -39,7 +39,6 @@
|
||||||
|
"serde",
|
||||||
|
"bytemuck",
|
||||||
|
"num-traits",
|
||||||
|
- "zerocopy",
|
||||||
|
]
|
||||||
|
rustc-args = [
|
||||||
|
"--cfg",
|
||||||
|
@@ -68,14 +67,6 @@
|
||||||
|
optional = true
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
-[dependencies.zerocopy]
|
||||||
|
-version = "0.6.0"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.3.5"
|
||||||
|
-
|
||||||
|
[dev-dependencies.quickcheck]
|
||||||
|
version = "1.0"
|
||||||
|
|
@ -0,0 +1,17 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Half-precision floating point f16 and bf16 types for Rust"
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused zerocopy feature (missing dependencies)",
|
||||||
|
"drop unused benchmark-only criterion dependency",
|
||||||
|
]
|
||||||
|
|
||||||
|
[tests]
|
||||||
|
skip = [
|
||||||
|
"bfloat::test::test_nan_conversion_to_larger",
|
||||||
|
"bfloat::test::test_nan_conversion_to_smaller",
|
||||||
|
"binary16::test::test_nan_conversion_to_larger",
|
||||||
|
"binary16::test::test_nan_conversion_to_smaller",
|
||||||
|
]
|
||||||
|
skip-exact = true
|
||||||
|
comments = ["skip tests that fail with Rust 1.75+ when built in release mode: https://github.com/starkat99/half-rs/issues/103"]
|
||||||
|
|
@ -0,0 +1,185 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate half
|
||||||
|
|
||||||
|
Name: rust-half1
|
||||||
|
Version: 1.8.3
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Half-precision floating point f16 and bf16 types for Rust
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/half
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused zerocopy feature (missing dependencies)
|
||||||
|
# * drop unused benchmark-only criterion dependency
|
||||||
|
Patch: half-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Half-precision floating point f16 and bf16 types for Rust implementing
|
||||||
|
the IEEE 754-2008 standard binary16 and bfloat16 types.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+bytemuck-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+bytemuck-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "bytemuck" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+bytemuck-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+num-traits-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+num-traits-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "num-traits" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+num-traits-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serialize-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serialize-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serialize" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serialize-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+use-intrinsics-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+use-intrinsics-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "use-intrinsics" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+use-intrinsics-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# * skip tests that fail with Rust 1.75+ when built in release mode:
|
||||||
|
# https://github.com/starkat99/half-rs/issues/103
|
||||||
|
%cargo_test -- -- --exact --skip bfloat::test::test_nan_conversion_to_larger --skip bfloat::test::test_nan_conversion_to_smaller --skip binary16::test::test_nan_conversion_to_larger --skip binary16::test::test_nan_conversion_to_smaller
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.8.3-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Wed Oct 23 2024 Fabio Valentini <decathorpe@gmail.com> - 1.8.3-1
|
||||||
|
- Update to version 1.8.3
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 23 2024 Fabio Valentini <decathorpe@gmail.com> - 1.8.2-2
|
||||||
|
- Skip tests that fail with Rust 1.75+ when built in release mode
|
||||||
|
|
||||||
|
* Sun Oct 15 2023 Fabio Valentini <decathorpe@gmail.com> - 1.8.2-1
|
||||||
|
- Initial import (half 1 compat package)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue