Update to version 2.4.0; Fixes RHBZ#2265959

epel10
Fabio Valentini 12 months ago
parent e7597d7dc1
commit 562a0f6f00
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -7,3 +7,4 @@
/half-1.7.1.crate
/half-1.8.2.crate
/half-2.3.1.crate
/half-2.4.0.crate

@ -1,6 +1,6 @@
--- half-2.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ half-2.3.1/Cargo.toml 2023-10-14T20:41:06.915241+00:00
@@ -107,5 +107,3 @@
--- half-2.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ half-2.4.0/Cargo.toml 2024-03-08T12:52:50.931270+00:00
@@ -111,5 +111,3 @@
std = ["alloc"]
use-intrinsics = []

@ -1,6 +1,6 @@
--- half-2.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ half-2.3.1/Cargo.toml 2023-10-14T20:41:18.538289+00:00
@@ -77,14 +77,6 @@
--- half-2.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ half-2.4.0/Cargo.toml 2024-03-08T12:53:03.710329+00:00
@@ -81,14 +81,6 @@
optional = true
default-features = false

@ -1,11 +1,11 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate half
Name: rust-half
Version: 2.3.1
Version: 2.4.0
Release: %autorelease
Summary: Half-precision floating point f16 and bf16 types for Rust
@ -15,8 +15,6 @@ Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: half-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused zerocopy feature (missing dependencies)
# * drop unused benchmark-only criterion dependency
Patch: half-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
@ -102,6 +100,18 @@ use the "rand_distr" feature of the "%{crate}" crate.
%files -n %{name}+rand_distr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -153,9 +163,7 @@ use the "use-intrinsics" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip tests that fail with Rust 1.75+ when built in release mode:
# https://github.com/starkat99/half-rs/issues/103
%cargo_test -- -- --exact --skip bfloat::test::test_nan_conversion_to_larger --skip bfloat::test::test_nan_conversion_to_smaller --skip binary16::test::test_nan_conversion_to_larger --skip binary16::test::test_nan_conversion_to_smaller
%cargo_test
%endif
%changelog

@ -1,13 +1,3 @@
[package]
summary = "Half-precision floating point f16 and bf16 types for Rust"
[tests]
skip = [
"bfloat::test::test_nan_conversion_to_larger",
"bfloat::test::test_nan_conversion_to_smaller",
"binary16::test::test_nan_conversion_to_larger",
"binary16::test::test_nan_conversion_to_smaller",
]
skip-exact = true
comments = ["skip tests that fail with Rust 1.75+ when built in release mode: https://github.com/starkat99/half-rs/issues/103"]

@ -1 +1 @@
SHA512 (half-2.3.1.crate) = b29acbca7b8f8fed6392346d03c710dad0f51cb2e358e7ea74a3aad4e10ffd22edb4154a56f877adc375da831a7597b51f7049335c0781a1b1110103e5eafc35
SHA512 (half-2.4.0.crate) = 7357a0f84dc6ae394efdd464f5a6da2bafa48bf8d794b2c34d1507d4d66af31ece8a012b58e6f76eacea2c249488a12c20f8c7e516ddd42a70633c9dbaa13bf5

Loading…
Cancel
Save