parent
43864879be
commit
8a72d017d8
@ -0,0 +1 @@
|
||||
/group-0.13.0.crate
|
@ -0,0 +1,20 @@
|
||||
--- group-0.13.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ group-0.13.0/Cargo.toml 2023-05-30T13:44:09.882393+00:00
|
||||
@@ -25,10 +25,6 @@
|
||||
version = "0.13"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.memuse]
|
||||
-version = "0.2"
|
||||
-optional = true
|
||||
-
|
||||
[dependencies.rand]
|
||||
version = "0.8"
|
||||
optional = true
|
||||
@@ -50,6 +46,5 @@
|
||||
alloc = []
|
||||
default = ["alloc"]
|
||||
tests = ["alloc", "rand", "rand_xorshift"]
|
||||
-wnaf-memuse = ["alloc", "memuse"]
|
||||
[badges.maintenance]
|
||||
status = "actively-developed"
|
@ -0,0 +1,123 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate group
|
||||
|
||||
Name: rust-group
|
||||
Version: 0.13.0
|
||||
Release: %autorelease
|
||||
Summary: Elliptic curve group traits and utilities
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/group
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused wnaf-memuse feature with missing dependencies
|
||||
Patch: group-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Elliptic curve group traits and utilities.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYRIGHT
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand_xorshift-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand_xorshift-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand_xorshift" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand_xorshift-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tests-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tests-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tests" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tests-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue