parent
bc0497d610
commit
f70d284a31
@ -0,0 +1 @@
|
|||||||
|
/grep-searcher-0.1.1.crate
|
@ -0,0 +1,10 @@
|
|||||||
|
--- grep-searcher-0.1.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ grep-searcher-0.1.1/Cargo.toml 2018-09-08T14:00:27.204896+02:00
|
||||||
|
@@ -46,7 +46,3 @@
|
||||||
|
|
||||||
|
[dev-dependencies.regex]
|
||||||
|
version = "1.0.5"
|
||||||
|
-
|
||||||
|
-[features]
|
||||||
|
-avx-accel = ["bytecount/avx-accel"]
|
||||||
|
-simd-accel = ["bytecount/simd-accel", "encoding_rs/simd-accel"]
|
@ -0,0 +1,72 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate grep-searcher
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.1.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Fast line oriented regex searching as a library
|
||||||
|
|
||||||
|
# Upstream license specification: Unlicense/MIT
|
||||||
|
License: Unlicense or MIT
|
||||||
|
URL: https://crates.io/crates/grep-searcher
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No SIMD
|
||||||
|
Patch0: grep-searcher-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(bytecount) >= 0.3.2 with crate(bytecount) < 0.4.0)
|
||||||
|
BuildRequires: (crate(encoding_rs) >= 0.8.6 with crate(encoding_rs) < 0.9.0)
|
||||||
|
BuildRequires: (crate(encoding_rs_io) >= 0.1.2 with crate(encoding_rs_io) < 0.2.0)
|
||||||
|
BuildRequires: (crate(grep-matcher) >= 0.1.1 with crate(grep-matcher) < 0.2.0)
|
||||||
|
BuildRequires: (crate(log) >= 0.4.5 with crate(log) < 0.5.0)
|
||||||
|
BuildRequires: (crate(memchr) >= 2.0.2 with crate(memchr) < 3.0.0)
|
||||||
|
BuildRequires: (crate(memmap) >= 0.6.2 with crate(memmap) < 0.7.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(grep-regex) >= 0.1.1 with crate(grep-regex) < 0.2.0)
|
||||||
|
BuildRequires: (crate(regex) >= 1.0.5 with crate(regex) < 2.0.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Fast line oriented regex searching as a library.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license UNLICENSE LICENSE-MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Sep 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.1-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue