Update to 0.1.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent ebca713806
commit 60713cb5aa
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/grep-searcher-0.1.1.crate /grep-searcher-0.1.1.crate
/grep-searcher-0.1.2.crate

@ -1,17 +1,9 @@
--- grep-searcher-0.1.1/Cargo.toml 1969-12-31T16:00:00-08:00 --- grep-searcher-0.1.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ grep-searcher-0.1.1/Cargo.toml 2018-11-27T12:23:40.233095-08:00 +++ grep-searcher-0.1.2/Cargo.toml 2019-02-10T09:26:02.074666+01:00
@@ -40,13 +40,9 @@ @@ -48,6 +48,4 @@
version = "2.0.2" version = "1.1"
[dependencies.memmap] [features]
-version = "0.6.2" -avx-accel = []
+version = "0.7" default = ["bytecount/runtime-dispatch-simd"]
[dev-dependencies.grep-regex] -simd-accel = ["encoding_rs/simd-accel"]
version = "0.1.1"
[dev-dependencies.regex]
version = "1.0.5"
-
-[features]
-avx-accel = ["bytecount/avx-accel"]
-simd-accel = ["bytecount/simd-accel", "encoding_rs/simd-accel"]

@ -6,32 +6,32 @@
%global crate grep-searcher %global crate grep-searcher
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.1 Version: 0.1.2
Release: 5%{?dist} Release: 1%{?dist}
Summary: Fast line oriented regex searching as a library Summary: Fast line oriented regex searching as a library
# Upstream license specification: Unlicense/MIT # Upstream license specification: Unlicense/MIT
License: Unlicense or MIT License: Unlicense or MIT
URL: https://crates.io/crates/grep-searcher URL: https://crates.io/crates/grep-searcher
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No SIMD # * No SIMD
# * bump to memmap 0.7
Patch0: grep-searcher-fix-metadata.diff Patch0: grep-searcher-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(bytecount/default) >= 0.3.2 with crate(bytecount/default) < 0.4.0) BuildRequires: (crate(bytecount/default) >= 0.5.0 with crate(bytecount/default) < 0.6.0)
BuildRequires: (crate(encoding_rs/default) >= 0.8.6 with crate(encoding_rs/default) < 0.9.0) BuildRequires: (crate(bytecount/runtime-dispatch-simd) >= 0.5.0 with crate(bytecount/runtime-dispatch-simd) < 0.6.0)
BuildRequires: (crate(encoding_rs_io/default) >= 0.1.2 with crate(encoding_rs_io/default) < 0.2.0) BuildRequires: (crate(encoding_rs/default) >= 0.8.14 with crate(encoding_rs/default) < 0.9.0)
BuildRequires: (crate(encoding_rs_io/default) >= 0.1.4 with crate(encoding_rs_io/default) < 0.2.0)
BuildRequires: (crate(grep-matcher/default) >= 0.1.1 with crate(grep-matcher/default) < 0.2.0) BuildRequires: (crate(grep-matcher/default) >= 0.1.1 with crate(grep-matcher/default) < 0.2.0)
BuildRequires: (crate(log/default) >= 0.4.5 with crate(log/default) < 0.5.0) BuildRequires: (crate(log/default) >= 0.4.5 with crate(log/default) < 0.5.0)
BuildRequires: (crate(memchr/default) >= 2.0.2 with crate(memchr/default) < 3.0.0) BuildRequires: (crate(memchr/default) >= 2.1.0 with crate(memchr/default) < 3.0.0)
BuildRequires: (crate(memmap/default) >= 0.7.0 with crate(memmap/default) < 0.8.0) BuildRequires: (crate(memmap/default) >= 0.7.0 with crate(memmap/default) < 0.8.0)
%if %{with check} %if %{with check}
BuildRequires: (crate(grep-regex/default) >= 0.1.1 with crate(grep-regex/default) < 0.2.0) BuildRequires: (crate(grep-regex/default) >= 0.1.1 with crate(grep-regex/default) < 0.2.0)
BuildRequires: (crate(regex/default) >= 1.0.5 with crate(regex/default) < 2.0.0) BuildRequires: (crate(regex/default) >= 1.1.0 with crate(regex/default) < 2.0.0)
%endif %endif
%global _description \ %global _description \
@ -66,7 +66,7 @@ which use "default" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%build %build
@ -81,6 +81,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-1
- Update to 0.1.2
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-5 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (grep-searcher-0.1.1.crate) = 523c8f994e01f34c403601795e6fedcc515e89f1f0188d2ced03f21c9abbe2aa61009705e393713b032a6346583f5ef79c722de6c58bca03f88f2ee283b3518c SHA512 (grep-searcher-0.1.2.crate) = e53f29c3b0102b9d89b014d92993a128401a39dfab75e8ce1b3c19303ed73cecd77356170f5b7ba4bd77b094eef63328a3350d3298c1145c7a5e2834b7d1a799

Loading…
Cancel
Save