Update to 0.1.6

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent f578d06d90
commit d770a66f49
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -3,3 +3,4 @@
/grep-regex-0.1.3.crate
/grep-regex-0.1.4.crate
/grep-regex-0.1.5.crate
/grep-regex-0.1.6.crate

@ -1,27 +0,0 @@
From cb2f6ddc61b79b7acf59bb00a6be9f1740aa55b8 Mon Sep 17 00:00:00 2001
From: Andrew Gallant <jamslam@gmail.com>
Date: Thu, 9 Jan 2020 20:58:28 -0500
Subject: [PATCH] deps: update to thread_local 1.0
We also update the pcre2 and regex dependencies, which removes any other
lingering uses of thread_local 0.3.
---
grep-regex/src/word.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/word.rs b/src/word.rs
index ff1e5dc3f6cb..9941bab02316 100644
--- a/src/word.rs
+++ b/src/word.rs
@@ -78,7 +78,7 @@ impl Matcher for WordMatcher {
// if it's worth it.
let cell = self.locs.get_or(|| {
- Box::new(RefCell::new(self.regex.capture_locations()))
+ RefCell::new(self.regex.capture_locations())
});
let mut caps = cell.borrow_mut();
self.regex.captures_read_at(&mut caps, haystack, at);
--
2.24.1

@ -1,8 +0,0 @@
--- grep-regex-0.1.5/Cargo.toml 1970-01-01T00:00:00+00:00
+++ grep-regex-0.1.5/Cargo.toml 2020-01-24T01:08:38.168482+00:00
@@ -37,4 +37,4 @@
version = "0.6.5"
[dependencies.thread_local]
-version = "0.3.6"
+version = "1"

@ -5,18 +5,14 @@
%global crate grep-regex
Name: rust-%{crate}
Version: 0.1.5
Release: 3%{?dist}
Version: 0.1.6
Release: 1%{?dist}
Summary: Use Rust's regex library with the 'grep' crate
# Upstream license specification: Unlicense/MIT
License: Unlicense or MIT
URL: https://crates.io/crates/grep-regex
Source: %{crates_source}
# Initial patched metadata
# * Bump to thread_local 1, https://github.com/BurntSushi/ripgrep/commit/cb2f6ddc61b79b7acf59bb00a6be9f1740aa55b8
Patch0: grep-regex-fix-metadata.diff
Patch1: 0001-deps-update-to-thread_local-1.0.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -75,6 +71,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Tue Mar 17 16:32:54 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.1.6-1
- Update to 0.1.6
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (grep-regex-0.1.5.crate) = 34322a607209c9a2c5fd2591aa6cc6a9570facb5484421cba63ed719baa3fb2d7b880407df6664ed97beed41433f6145d36f17d1261030b885157dbeda18a2f5
SHA512 (grep-regex-0.1.6.crate) = 8bf782ff6108590ef1380659b7a25ef012bc0bbba8827fba233724c567caf4d768edb2c8e765937a46597effb49885849728f341f6b513b7457f0156fe7f8cb9

Loading…
Cancel
Save