parent
0b70bfd74f
commit
2ab33a333f
@ -0,0 +1 @@
|
||||
/globset-0.2.1.crate
|
@ -0,0 +1,7 @@
|
||||
--- globset-0.2.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ globset-0.2.1/Cargo.toml 2017-11-09T09:09:13.471327+01:00
|
||||
@@ -43,4 +43,3 @@
|
||||
version = "0.2"
|
||||
|
||||
[features]
|
||||
-simd-accel = ["regex/simd-accel"]
|
@ -0,0 +1,82 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate globset
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Single glob and glob set matching
|
||||
|
||||
License: Unlicense or MIT
|
||||
URL: https://crates.io/crates/globset
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No simd
|
||||
Patch0: globset-0.2.1-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(aho-corasick) >= 0.6.0 with crate(aho-corasick) < 0.7.0)
|
||||
BuildRequires: (crate(fnv) >= 1.0.0 with crate(fnv) < 2.0.0)
|
||||
BuildRequires: (crate(log) >= 0.3.0 with crate(log) < 0.4.0)
|
||||
BuildRequires: (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
|
||||
BuildRequires: (crate(regex) >= 0.2.1 with crate(regex) < 0.3.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(glob) >= 0.2.0 with crate(glob) < 0.3.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Cross platform single glob and glob set matching. Glob set matching is the
|
||||
process of matching one or more glob patterns against a single candidate path
|
||||
simultaneously, and returning all of the globs that matched.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license COPYING UNLICENSE LICENSE-MIT
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Thu Nov 09 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
|
||||
- Update to 0.2.1
|
||||
|
||||
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-1
|
||||
- Update to 0.2.0
|
||||
|
||||
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.4-2
|
||||
- Port to use rust-packaging
|
||||
|
||||
* Wed Mar 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.4-1
|
||||
- Update to 0.1.4
|
||||
|
||||
* Sat Feb 25 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-1
|
||||
- Initial package
|
Loading…
Reference in new issue