Initial import (#2228524)
parent
34243baa6f
commit
834d61123c
@ -0,0 +1 @@
|
|||||||
|
/gix-url-0.21.1.crate
|
@ -0,0 +1,22 @@
|
|||||||
|
--- gix-url-0.21.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ gix-url-0.21.1/Cargo.toml 2023-08-02T14:07:57.852757+00:00
|
||||||
|
@@ -20,7 +20,7 @@
|
||||||
|
"LICENSE-*",
|
||||||
|
"CHANGELOG.md",
|
||||||
|
]
|
||||||
|
-description = "A WIP crate of the gitoxide project implementing parsing and serialization of gix-url"
|
||||||
|
+description = "Implementation of parsing and serialization of URLs for gix"
|
||||||
|
license = "MIT OR Apache-2.0"
|
||||||
|
repository = "https://github.com/Byron/gitoxide"
|
||||||
|
|
||||||
|
@@ -39,10 +39,6 @@
|
||||||
|
version = "1.3.0"
|
||||||
|
features = ["std"]
|
||||||
|
default-features = false
|
||||||
|
-
|
||||||
|
-[dependencies.document-features]
|
||||||
|
-version = "0.2.0"
|
||||||
|
-optional = true
|
||||||
|
|
||||||
|
[dependencies.gix-features]
|
||||||
|
version = "^0.32.1"
|
@ -0,0 +1,85 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate gix-url
|
||||||
|
|
||||||
|
Name: rust-gix-url
|
||||||
|
Version: 0.21.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Implementation of parsing and serialization of URLs for gix
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/gix-url
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * improve crate summary / description
|
||||||
|
# * drop unused optional dependency that is only useful for building docs
|
||||||
|
Patch: gix-url-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Implementation of parsing and serialization of URLs for gix.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue