parent
7e78b8c121
commit
513731bef5
@ -0,0 +1,2 @@
|
||||
/gix-trace-0.1.1.crate
|
||||
/gix-trace-0.1.2.crate
|
@ -0,0 +1,13 @@
|
||||
--- gix-trace-0.1.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ gix-trace-0.1.1/Cargo.toml 2023-06-28T16:05:24.252314+00:00
|
||||
@@ -31,10 +31,6 @@
|
||||
test = false
|
||||
doctest = false
|
||||
|
||||
-[dependencies.document-features]
|
||||
-version = "0.2.0"
|
||||
-optional = true
|
||||
-
|
||||
[dependencies.tracing-core]
|
||||
version = "0.1.31"
|
||||
optional = true
|
@ -0,0 +1,98 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate gix-trace
|
||||
|
||||
Name: rust-gix-trace
|
||||
Version: 0.1.2
|
||||
Release: %autorelease
|
||||
Summary: Minimal tracing support for gitoxide that can be turned off to zero cost
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/gix-trace
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * Documentation feature is not needed for fedora
|
||||
Patch: gix-trace-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A crate to provide minimal `tracing` support that can be turned off to
|
||||
zero cost.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tracing-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tracing-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tracing" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tracing-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tracing-detail-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tracing-detail-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tracing-detail" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tracing-detail-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,2 @@
|
||||
[DEFAULT]
|
||||
summary = Minimal tracing support for gitoxide that can be turned off to zero cost
|
Loading…
Reference in new issue