commit
2084907dfc
@ -0,0 +1 @@
|
|||||||
|
SOURCES/gix-path-0.10.13.crate
|
@ -0,0 +1 @@
|
|||||||
|
4ee9d9df68bff5a217f975a5099294148f73240d SOURCES/gix-path-0.10.13.crate
|
@ -0,0 +1,24 @@
|
|||||||
|
--- gix-path-0.10.13/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ gix-path-0.10.13/Cargo.toml 2024-11-26T19:26:56.087266+00:00
|
||||||
|
@@ -54,16 +54,6 @@
|
||||||
|
|
||||||
|
[target.'cfg(not(target_family = "wasm"))'.dependencies.home]
|
||||||
|
version = "0.5.5"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dev-dependencies.known-folders]
|
||||||
|
-version = "1.1.0"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dev-dependencies.windows]
|
||||||
|
-version = "0.58.0"
|
||||||
|
-features = ["Win32_System_Threading"]
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dev-dependencies.winreg]
|
||||||
|
-version = "0.52.0"
|
||||||
|
|
||||||
|
[lints.clippy]
|
||||||
|
bool_to_int_with_if = "allow"
|
||||||
|
@@ -139,3 +129,4 @@
|
||||||
|
priority = -1
|
||||||
|
|
||||||
|
[lints.rust]
|
||||||
|
+
|
@ -0,0 +1,9 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Utility crate for handling paths in gix"
|
||||||
|
|
||||||
|
[tests]
|
||||||
|
run = ["none"]
|
||||||
|
comments = [
|
||||||
|
"Deactivate tests because of a missing dev-dependency (gix-testtools)",
|
||||||
|
"See https://github.com/Byron/gitoxide/discussions/900 for more information"
|
||||||
|
]
|
@ -0,0 +1,124 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 27
|
||||||
|
# * Deactivate tests because of a missing dev-dependency (gix-testtools)
|
||||||
|
# * See https://github.com/Byron/gitoxide/discussions/900 for more information
|
||||||
|
%bcond check 0
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate gix-path
|
||||||
|
|
||||||
|
Name: rust-gix-path
|
||||||
|
Version: 0.10.13
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Utility crate for handling paths in gix
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/gix-path
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip dependencies and normalize metadata
|
||||||
|
Patch: gix-path-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A crate of the gitoxide project dealing paths and their conversions.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.10.13-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Nov 28 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.13-1
|
||||||
|
- Update to version 0.10.13; Fixes RHBZ#2321173
|
||||||
|
|
||||||
|
* Tue Sep 10 2024 blinxen <h-k-81@hotmail.com> - 0.10.11-1
|
||||||
|
- Update to version 0.10.11 (rhbz#2307394)
|
||||||
|
|
||||||
|
* Thu Jul 25 2024 blinxen <h-k-81@hotmail.com> - 0.10.9-1
|
||||||
|
- Update to version 0.10.9 (rhbz#2298620)
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.8-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 26 2024 blinxen <h-k-81@hotmail.com> - 0.10.8-1
|
||||||
|
- Update to version 0.10.8 (rhbz#2293947)
|
||||||
|
|
||||||
|
* Fri Apr 05 2024 blinxen <h-k-81@hotmail.com> - 0.10.7-1
|
||||||
|
- Update to version 0.10.7 (rhbz#2265916)
|
||||||
|
|
||||||
|
* Tue Jan 30 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.5-1
|
||||||
|
- Update to version 0.10.5; Fixes RHBZ#2253238
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Sep 13 2023 blinxen <h-k-81@hotmail.com> - 0.10.0-1
|
||||||
|
- Update to version 0.10.0 (rhbz#2233476)
|
||||||
|
|
||||||
|
* Thu Jul 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-1
|
||||||
|
- Update to version 0.8.4; Fixes RHBZ#2224744
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 04 2023 blinxen <h-k-81@hotmail.com> - 0.8.3-1
|
||||||
|
- Update to version 0.8.3 (rhbz#2216739)
|
||||||
|
|
||||||
|
* Tue Jun 06 2023 blinxen <h-k-81@hotmail.com> - 0.8.1-1
|
||||||
|
- Initial package
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue