Initial import (#2228212)
parent
741f2c8add
commit
d0673a8028
@ -0,0 +1 @@
|
||||
/gix-packetline-0.16.4.crate
|
@ -0,0 +1,22 @@
|
||||
--- gix-packetline-0.16.4/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ gix-packetline-0.16.4/Cargo.toml 2023-08-01T18:14:28.753667+00:00
|
||||
@@ -20,7 +20,7 @@
|
||||
"LICENSE-*",
|
||||
"CHANGELOG.md",
|
||||
]
|
||||
-description = "A WIP crate of the gitoxide project implementing the pkt-line serialization format"
|
||||
+description = "Implementation of the the pkt-line serialization format for gix"
|
||||
license = "MIT OR Apache-2.0"
|
||||
repository = "https://github.com/Byron/gitoxide"
|
||||
|
||||
@@ -55,10 +55,6 @@
|
||||
version = "1.3.0"
|
||||
features = ["std"]
|
||||
default-features = false
|
||||
-
|
||||
-[dependencies.document-features]
|
||||
-version = "0.2.0"
|
||||
-optional = true
|
||||
|
||||
[dependencies.futures-io]
|
||||
version = "0.3.16"
|
@ -0,0 +1,145 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate gix-packetline
|
||||
|
||||
Name: rust-gix-packetline
|
||||
Version: 0.16.4
|
||||
Release: %autorelease
|
||||
Summary: Implementation of the the pkt-line serialization format for gix
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/gix-packetline
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * improve crate summary / description
|
||||
# * drop unused optional dependency that is only useful for building docs
|
||||
Patch: gix-packetline-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Implementation of the the pkt-line serialization format for gix.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+async-io-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+async-io-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "async-io" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+async-io-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+blocking-io-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+blocking-io-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "blocking-io" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+blocking-io-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-io-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-io-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-io" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-io-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-lite-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-lite-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-lite" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-lite-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pin-project-lite-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pin-project-lite-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pin-project-lite" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pin-project-lite-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue