parent
510695504b
commit
adc7e93cbc
@ -0,0 +1 @@
|
||||
/gix-pack-0.42.0.crate
|
@ -0,0 +1,10 @@
|
||||
--- gix-pack-0.42.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ gix-pack-0.42.0/Cargo.toml 2023-09-26T20:03:46.387180+00:00
|
||||
@@ -124,7 +124,6 @@
|
||||
"gix-object/serde",
|
||||
]
|
||||
streaming-input = []
|
||||
-wasm = ["gix-diff?/wasm"]
|
||||
|
||||
[target."cfg(not(target_arch = \"wasm32\"))".dependencies.gix-tempfile]
|
||||
version = "^9.0.0"
|
@ -0,0 +1,157 @@
|
||||
# Generated by rust2rpm 24
|
||||
# Deactivate tests because of a missing dev-dependency (gix-testtools)
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate gix-pack
|
||||
|
||||
Name: rust-gix-pack
|
||||
Version: 0.42.0
|
||||
Release: %autorelease
|
||||
Summary: Implements git packs and related data structures
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/gix-pack
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * Drop wasm feature as Fedora does not support building against wasm targets
|
||||
Patch: gix-pack-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Implements git packs and related data structures.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+document-features-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+document-features-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "document-features" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+document-features-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+generate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+generate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "generate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+generate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+object-cache-dynamic-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+object-cache-dynamic-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "object-cache-dynamic" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+object-cache-dynamic-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pack-cache-lru-dynamic-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pack-cache-lru-dynamic-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pack-cache-lru-dynamic" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pack-cache-lru-dynamic-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pack-cache-lru-static-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pack-cache-lru-static-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pack-cache-lru-static" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pack-cache-lru-static-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+streaming-input-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+streaming-input-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "streaming-input" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+streaming-input-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue