import rust-gix-features-0.38.2-3.el10

i10ce changed/i10ce/rust-gix-features-0.38.2-3.el10
MSVSphere Packaging Team 4 weeks ago
commit 694cc0d013
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/gix-features-0.38.2.crate

@ -0,0 +1 @@
1fd14113d4421290e89e4651d1676d1917a8ce3e SOURCES/gix-features-0.38.2.crate

@ -0,0 +1,11 @@
--- gix-features-0.38.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gix-features-0.38.2/Cargo.toml 2024-09-15T12:55:50.061759+00:00
@@ -88,7 +88,7 @@
default-features = false
[dependencies.prodash]
-version = "28.0.0"
+version = "29.0.0"
optional = true
default-features = false

@ -0,0 +1,6 @@
[package]
summary = "Integrate various capabilities using compile-time feature flags"
[features]
# The flate2/zlib-ng-compat feature is hidden because not all Fedora releases
# have both zlib-ng and zlib-compat libraries included.
hide = ["zlib-ng-compat"]

@ -0,0 +1,377 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 3;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate gix-features
Name: rust-gix-features
Version: 0.38.2
Release: %autorelease
Summary: Integrate various capabilities using compile-time feature flags
License: MIT OR Apache-2.0
URL: https://crates.io/crates/gix-features
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Bump prodash to 0.29.0 to match it with the version used in the gix crate
Patch: gix-features-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A crate to integrate various capabilities using compile-time feature
flags.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cache-efficiency-debug-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cache-efficiency-debug-devel %{_description}
This package contains library source intended for building other packages which
use the "cache-efficiency-debug" feature of the "%{crate}" crate.
%files -n %{name}+cache-efficiency-debug-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crc32-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crc32-devel %{_description}
This package contains library source intended for building other packages which
use the "crc32" feature of the "%{crate}" crate.
%files -n %{name}+crc32-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fast-sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "fast-sha1" feature of the "%{crate}" crate.
%files -n %{name}+fast-sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fs-read-dir-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fs-read-dir-devel %{_description}
This package contains library source intended for building other packages which
use the "fs-read-dir" feature of the "%{crate}" crate.
%files -n %{name}+fs-read-dir-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fs-walkdir-parallel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fs-walkdir-parallel-devel %{_description}
This package contains library source intended for building other packages which
use the "fs-walkdir-parallel" feature of the "%{crate}" crate.
%files -n %{name}+fs-walkdir-parallel-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io-pipe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+io-pipe-devel %{_description}
This package contains library source intended for building other packages which
use the "io-pipe" feature of the "%{crate}" crate.
%files -n %{name}+io-pipe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+once_cell-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parallel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parallel-devel %{_description}
This package contains library source intended for building other packages which
use the "parallel" feature of the "%{crate}" crate.
%files -n %{name}+parallel-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+prodash-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+prodash-devel %{_description}
This package contains library source intended for building other packages which
use the "prodash" feature of the "%{crate}" crate.
%files -n %{name}+prodash-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-devel %{_description}
This package contains library source intended for building other packages which
use the "progress" feature of the "%{crate}" crate.
%files -n %{name}+progress-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-unit-bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-unit-bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-unit-bytes" feature of the "%{crate}" crate.
%files -n %{name}+progress-unit-bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-unit-human-numbers-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-unit-human-numbers-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-unit-human-numbers" feature of the "%{crate}" crate.
%files -n %{name}+progress-unit-human-numbers-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustsha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustsha1-devel %{_description}
This package contains library source intended for building other packages which
use the "rustsha1" feature of the "%{crate}" crate.
%files -n %{name}+rustsha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tracing-devel %{_description}
This package contains library source intended for building other packages which
use the "tracing" feature of the "%{crate}" crate.
%files -n %{name}+tracing-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tracing-detail-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tracing-detail-devel %{_description}
This package contains library source intended for building other packages which
use the "tracing-detail" feature of the "%{crate}" crate.
%files -n %{name}+tracing-detail-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+walkdir-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+walkdir-devel %{_description}
This package contains library source intended for building other packages which
use the "walkdir" feature of the "%{crate}" crate.
%files -n %{name}+walkdir-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zlib-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zlib-devel %{_description}
This package contains library source intended for building other packages which
use the "zlib" feature of the "%{crate}" crate.
%files -n %{name}+zlib-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zlib-ng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zlib-ng-devel %{_description}
This package contains library source intended for building other packages which
use the "zlib-ng" feature of the "%{crate}" crate.
%files -n %{name}+zlib-ng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zlib-rust-backend-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zlib-rust-backend-devel %{_description}
This package contains library source intended for building other packages which
use the "zlib-rust-backend" feature of the "%{crate}" crate.
%files -n %{name}+zlib-rust-backend-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zlib-stock-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zlib-stock-devel %{_description}
This package contains library source intended for building other packages which
use the "zlib-stock" feature of the "%{crate}" crate.
%files -n %{name}+zlib-stock-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.38.2-3
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sun Sep 15 2024 blinxen <h-k-81@hotmail.com> - 0.38.2-3
- Bump prodash dependency to 0.29.0 to match it with the version used in
the latest gix update
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.38.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Sun Jun 23 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.38.2-1
- Update to 0.38.2 (close RHBZ#2282448)
* Sat Jun 22 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.38.1-2
- Stop hiding the zlib-ng feature
* Fri Apr 05 2024 blinxen <h-k-81@hotmail.com> - 0.38.1-1
- Update to version 0.38.1 (rhbz#2253235)
* Mon Feb 19 2024 Fabio Valentini <decathorpe@gmail.com> - 0.36.1-1
- Update to version 0.36.1
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.36.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Fri Oct 13 2023 blinxen <h-k-81@hotmail.com> - 0.36.0-1
- Update to version 0.36.0
* Thu Oct 05 2023 blinxen <h-k-81@hotmail.com> - 0.35.0-1
- Update to version 0.35.0 (rhbz#2240469)
* Wed Sep 13 2023 blinxen <h-k-81@hotmail.com> - 0.34.0-1
- Update to version 0.34.0 (rhbz#2233473)
* Thu Jul 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.32.1-1
- Update to version 0.32.1; Fixes RHBZ#2218496
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Wed Jun 28 2023 blinxen <h-k-81@hotmail.com> - 0.30.0-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save