Initial package (rhbz#2239505)

epel9
blinxen 1 year ago
parent 0423083c5a
commit 8dad6b6cb1

1
.gitignore vendored

@ -0,0 +1 @@
/gix-diff-0.35.0.crate

@ -1,3 +0,0 @@
# rust-gix-diff
The rust-gix-diff package

@ -0,0 +1,20 @@
--- gix-diff-0.35.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gix-diff-0.35.0/Cargo.toml 2023-09-21T19:17:24.469076+00:00
@@ -40,12 +40,6 @@
version = "0.2.0"
optional = true
-[dependencies.getrandom]
-version = "0.2.8"
-features = ["js"]
-optional = true
-default-features = false
-
[dependencies.gix-hash]
version = "^0.13.0"
@@ -73,4 +67,3 @@
"gix-hash/serde",
"gix-object/serde",
]
-wasm = ["dep:getrandom"]

@ -0,0 +1,108 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate gix-diff
Name: rust-gix-diff
Version: 0.35.0
Release: %autorelease
Summary: Calculate differences between various git objects
License: MIT OR Apache-2.0
URL: https://crates.io/crates/gix-diff
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Drop wasm feature as Fedora does not support building against wasm targets
Patch: gix-diff-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Calculate differences between various git objects.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blob-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blob-devel %{_description}
This package contains library source intended for building other packages which
use the "blob" feature of the "%{crate}" crate.
%files -n %{name}+blob-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (gix-diff-0.35.0.crate) = e35dd5dde292dca14becad61f8f9c74cd2f85fc6dcdb4328ff617b66d39e747885c9463b5e39cb2a71db4b3468177b3c7904bf726118de28172f0bbce77efd50
Loading…
Cancel
Save